
	
	

	

	
	

	



<!doctype html>
<html lang="fi">
<head>

	<meta charset="UTF-8">

	<link rel="preconnect" href="https://cdn.afterdawn.fi" crossorigin />

	

	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Courgette&display=swap" />

	<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Courgette&display=swap' rel="stylesheet" media="print" onload="this.media='all'">

	<noscript>
		<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Courgette&display=swap' rel="stylesheet" />
	</noscript>

	

	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=1.0, user-scalable=1" />
	<meta name="HandheldFriendly" content="true">

	<meta name="theme-color" content="#004659">
	
	

		

		<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
		<script>
		  var OneSignal = OneSignal || [];
			OneSignal.push(["init", {
			  appId: "93d08ca6-cfa1-4d6c-a9e9-6494a1c27602",
			}]);
		</script>
		
		

		<!-- Global site tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2099875-2"></script>
		<script>
		  window.dataLayer = window.dataLayer || [];
		  function gtag(){dataLayer.push(arguments);}
		  gtag('js', new Date());

		  gtag('config', 'UA-2099875-2');
		</script>

	

	
		<title>Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet - AfterDawn</title>
		
			<meta name="author" content="Janne Yli-Korhonen">
		
		<link rel="shortcut icon" href="https://cdn.afterdawn.fi/v4/favicon.ico">
		<meta http-equiv="Content-Language" content="fi" />
		
			
				
		
			
			
				
				<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="canonical" href="https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta"> <link rel="amphtml" href="https://fin.afterdawn.com/amp/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta"> 
					<meta name="news_keywords" content="Huawei,Huawei FreeBuds Pro 2,kuulokkeet,hinta" />
		<meta name="robots" content="max-image-preview:large">
				<script type="application/ld+json">
				{
				  "@context": "https://schema.org",
				  "@type": "BreadcrumbList",
				  "itemListElement": [{
					"@type": "ListItem",
					"position": 1,
					"name": "Uutiset",
					"item": "https://fin.afterdawn.com/uutiset/"
				  },{
					"@type": "ListItem",
					"position": 2,
					"name": "Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet",
					"item": "https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta"
				  }]
				}
				</script>
			
		
			<script type="application/ld+json">
			{
			"@context": "https://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": "https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta",
			"headline": "Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet",
			"datePublished": "August, 08 2022 10:44:52 +0000",
			"dateModified": "August, 08 2022 10:44:52 +0000",

			
				"description": "Huawei on tuonut hinnan osalta huippuluokkaan kuuluvat FreeBuds Pro 2 -kuulokkeet saataville Suomessa. Kuulokkeissa on panostettu äänentoistoon ja taustamelun vähentämiseen.",
			

			
				"author": {
					"@type": "Person",
					"name": "Janne Yli-Korhonen",
					"url": "https://fin.afterdawn.com/bio/jyk"
				},
			

			"publisher": {
			  "@type": "Organization",
			  "name": "AfterDawn",
			  "logo": {
				"@type": "ImageObject",
				"url": "https://cdn.afterdawn.fi/storage/pictures/afterdawn-logo-181x60.jpg",
				"width": 181,
				"height": 60
			  }
			}

			
				,
				"image": [
				  "https://cdn.afterdawn.fi/v3/news/original/Huawei-freebuds-pro-2-image-blue.jpg",
				  "https://cdn.afterdawn.fi/v3/news/600x400/Huawei-freebuds-pro-2-image-blue.jpg"
				]
			

				}
			</script>

		
	
		<meta property="og:title" content="Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet">
		<meta property="og:type" content="article">
		<meta property="og:url" content="https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta">
		<meta property="og:image" content="https://cdn.afterdawn.fi/v3/news/original/Huawei-freebuds-pro-2-image-blue.jpg">
		<meta property="og:site_name" content="AfterDawn">
		<meta property="fb:app_id" content="121480884529558" />
	
				<meta name="twitter:card" content="summary_large_image">
				<meta name="twitter:site" content="@afterdawnfi">
				
					<meta name="twitter:creator" content="@yyyykoooo">
				
				<meta name="twitter:title" content="Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet">
				
					<meta name="twitter:description" content="Huawei on tuonut hinnan osalta huippuluokkaan kuuluvat FreeBuds Pro 2 -kuulokkeet saataville Suomessa. Kuulokkeissa on panostettu äänentoistoon ja taustamelun vähentämiseen.">
				
				<meta name="twitter:image:src" content="https://cdn.afterdawn.fi/v3/news/600x400/Huawei%2Dfreebuds%2Dpro%2D2%2Dimage%2Dblue%2Ejpg">
			
		
		<meta name="description" content="Huawei on tuonut hinnan osalta huippuluokkaan kuuluvat FreeBuds Pro 2 -kuulokkeet saataville Suomessa. Kuulokkeissa on panostettu äänentoistoon ja taustamelun vähentämiseen." />
		<link rel="apple-touch-icon" href="https://cdn.afterdawn.fi/v3/apple-touch-icon.png">

		

		

		
			<link rel="alternate" type="application/rss+xml" href="http://feeds.afterdawn.com/afterdawn" title="AfterDawn: News" />
		
		
		

		

	
	
	
	
	

	

	<script>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</script>



	
		
			<link rel="preload" href="https://fin.afterdawn.com/css/styles-min.css?20220801-01" as="style">
			<link rel="stylesheet" href="https://fin.afterdawn.com/css/styles-min.css?20220801-01">
		
	

	

	<script async='async' src='https://macro.adnami.io/macro/spec/adsm.macro.345df3b5-bf65-432a-a1eb-f24ca6a1231c.js'></script> 
	<script> 
	var adsmtag = adsmtag || {}; 
	adsmtag.cmd = adsmtag.cmd || []; 
	</script>

	<link rel="preload" href="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" as="script" crossorigin="anonymous">
	<script src="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" crossorigin="anonymous"></script>

	


</head>
<body>

	<header class="no-max-width header">
		
			<div class="sites">
				
					<ul class="menu-sites">
						<li><a href="https://fin.afterdawn.com/">AfterDawn</a></li>
						<li><a href="https://www.puhelinvertailu.com/">Puhelinvertailu</a></li>
						<li><a href="https://www.hardware.fi/">Hardware.fi</a></li>
						<li><a href="https://www.download.fi/">download.fi</a></li>
						<li><a href="https://x2.fi/">X2.fi</a></li>
						<li><a href="https://high.fi/">HIGH.FI</a></li>
					</ul>
				
				
				
				<div class="login-dropdown not-logged-in">
					<img class="user-logo" src="https://cdn.afterdawn.fi/x2fi/responsive/img/person-icon.png" alt="User img">
					<div class="login-dropdown_panel">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a><br/>
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
				</div>
				
			</div>
			
		
		
		<div class="max-width">

			
			<div class="header-burger">
				<div></div>
				<div></div>
				<div></div>
			</div>
			
			
			

				
			
				<div class="mobile-dropdown">
					<div class="mobile-dropdown_close">
						<div></div>
						<div></div>
					</div>
					<ul class="mobile-dropdown_menu">
						<li><a href="https://fin.afterdawn.com/" class="dropdown-link">Etusivu</a></li>
						<li><a href="https://fin.afterdawn.com/uutiset/" class="dropdown-link">Uutiset</a></li>
						<li><a href="https://fin.afterdawn.com/arvostelut/" class="dropdown-link">Arvostelut</a></li>
						<li><a href="https://fin.afterdawn.com/oppaat/" class="dropdown-link">Oppaat</a></li>
						<li><a href="https://fin.afterdawn.com/paivan-diili" class="dropdown-link">Tarjoukset</a></li>
						<li><a href="https://fin.afterdawn.com/parhaat" class="dropdown-link">Parhaat</a></li>
						<li><a href="https://keskustelu.afterdawn.com/" class="dropdown-link">Keskustelu</a></li>
					</ul>
					<div class="mobile-dropdown_panel not-logged-in">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a>
							<a class="dropdown-link register-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
					<div class="mobile-dropdown_social">
						<a class="social-link fb-link" href="https://www.facebook.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link tw-link" href="https://twitter.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link inst-link" href="https://instagram.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
					</div>
				</div>

				

				
				<a href="https://fin.afterdawn.com/" class="branding" title="AfterDawnin Etusivulle">
					<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" alt="AfterDawn logo">
				</a>
				


				<a class="search" href="#"></a>
				<form class="search-form-m" method="get" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm">
					<input type="search" value="" name="q" placeholder="Hae uutisia..." />
					<input type="submit" value="">
				</form>

				<nav>
					<ul class="menu-main">
						
							<li><a href="https://fin.afterdawn.com/">Etusivu</a></li>
						
							<li><a href="https://fin.afterdawn.com/uutiset/" class="active">Uutiset</a></li>
						
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
						
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						
							<li><a href="https://fin.afterdawn.com/paivan-diili">Tarjoukset</a></li>
						
							<li><a href="https://fin.afterdawn.com/parhaat">Parhaat</a></li>
						
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
						
						
						<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb-m" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
						<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter-m" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
					</ul>
				</nav>
				
				<form class="search-form" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm" method="get">
					<input type="search" value="" name="q" placeholder="Hae uutisia...">
					<input type="submit" value="Hae">
				</form>
			
			

			
			<ul class="menu-some">
				<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
				<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
			</ul>
			
			

		</div>
	</header>

	<div class="no-max-width">
		<ul class="max-width menu-tags">
			
			
				
				<li><a href="https://fin.afterdawn.com/t/robotti-imuri">Robotti-imurit</a></li>
				<li><a href="https://fin.afterdawn.com/t/kuulokkeiden_arvostelut">Kuulokkeet</a></li>
				<li><a href="https://fin.afterdawn.com/t/robottiruohonleikkuri">Robottiruohonleikkuri</a></li>
				<li><a href="https://fin.afterdawn.com/t/sahkopotkulauta">S&auml;hk&ouml;potkulaudat</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2022/06/30/paras-naytonohjain">Parhaat n&auml;yt&ouml;nohjaimet</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2021/06/22/paras-bluetooth-kaiutin">Parhaat Bluetooth-kaiuttimet</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2021/02/26/halpa-peli-pc">Rakenna halpa peli-PC</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2020/09/15/opas-kovalevyn-vaihto-tietokoneeseen-ssd-tai-hdd">Opas: Kovalevyn vaihto</a></li>
			
			
			
		</ul>
	</div>
	<div class="max-width">



		<div id="nm-160x600" class="ad-160"></div>

		<div class="col1 pin-container">
			<aside class="col1-inner pinned">
				<nav class="menu-sub">

					

					

					

					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/08/05/duckduckgo-microsoft-seuraimet-esto" title="DuckDuckGo estää nyt myös Microsoftin seuraimet, joita ei aiemmin estetty"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/DuckDuckGo-logo-black.jpg" alt="DuckDuckGo estää nyt myös Microsoftin seuraimet, joita ei aiemmin estetty" />
								<div class="info">
									<time datetime="2022-08-05T16:02:50Z" class="timeago published">5. August, 2022 19:02</time>
									
								</div>
								<div class="curtain"></div>
								<h3>DuckDuckGo estää nyt myös Microsoftin seuraimet, joita ei aiemmin estetty</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/05/amazon-irobot-roomba-yrityskauppa" title="Hurja yrityskauppa: Verkkokauppajätti Amazon ostaa Roomban valmistajan, iRobotin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/roomba-i7plus-arvostelu.jpg" alt="Hurja yrityskauppa: Verkkokauppajätti Amazon ostaa Roomban valmistajan, iRobotin" />
								<div class="info">
									<time datetime="2022-08-05T14:12:47Z" class="timeago published">5. August, 2022 17:12</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Hurja yrityskauppa: Verkkokauppajätti Amazon ostaa Roomban valmistajan, iRobotin</h3>
							</li>
						
					</ul>

					<div id="nm-300x600-300x300" class="ad-300"></div>


					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/08/05/hbo-max-ja-discovery-plus-yhdistyminen-eurooppa-2024" title="HBO Max ja Discovery+ yhdistyvät Euroopassa vuoden 2024 alussa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/HBO-Max-nordic.jpg" alt="HBO Max ja Discovery+ yhdistyvät Euroopassa vuoden 2024 alussa" />
								<div class="info">
									<time datetime="2022-08-05T10:54:9Z" class="timeago published">5. August, 2022 13:54</time>
									
								</div>
								<div class="curtain"></div>
								<h3>HBO Max ja Discovery+ yhdistyvät Euroopassa vuoden 2024 alussa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/paivan-diili-suomen-halvin-1tb-ssd-levy-55-euroa" title="Päivän diili: Suomen halvin 1TB SSD-levy? 55 euroa (Päivitys: tarjoustuote myyty loppuun)"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/patriot-p210-ssd.jpg" alt="Päivän diili: Suomen halvin 1TB SSD-levy? 55 euroa (Päivitys: tarjoustuote myyty loppuun)" />
								<div class="info">
									<time datetime="2022-08-04T16:35:24Z" class="timeago published">4. August, 2022 19:35</time>
									<a class="comments" href="/uutiset/2022/08/04/paivan-diili-suomen-halvin-1tb-ssd-levy-55-euroa#kommentit">3</a>
								</div>
								<div class="curtain"></div>
								<h3>Päivän diili: Suomen halvin 1TB SSD-levy? 55 euroa (Päivitys: tarjoustuote myyty loppuun)</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/winamp-5-9-rc1-julkaistiin" title="Neljän vuoden odotus on ohi: Laaman takamus paukkuu taas, Winamp 5.9 RC1 julkaistiin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/winamp-screenshot.jpg" alt="Neljän vuoden odotus on ohi: Laaman takamus paukkuu taas, Winamp 5.9 RC1 julkaistiin" />
								<div class="info">
									<time datetime="2022-08-04T16:14:32Z" class="timeago published">4. August, 2022 19:14</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Neljän vuoden odotus on ohi: Laaman takamus paukkuu taas, Winamp 5.9 RC1 julkaistiin</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/yle-areena-ongelma-video-audio-ei-toimi" title="Yle Areenassa ongelmia - videot ja audiot eivät toimi (Päivitys: toimii taas)"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Yle-Areena-vikailmoitus.jpg" alt="Yle Areenassa ongelmia - videot ja audiot eivät toimi (Päivitys: toimii taas)" />
								<div class="info">
									<time datetime="2022-08-04T15:15:47Z" class="timeago published">4. August, 2022 18:15</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Yle Areenassa ongelmia - videot ja audiot eivät toimi (Päivitys: toimii taas)</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/lg-stadia-pro-ilmainen-kolme-kuukautta" title="LG:n television omistajat saavat nyt ilmaiseksi kolme kuukautta Stadia Pro -tilausta"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/stadia-pro-LG-TV.jpg" alt="LG:n television omistajat saavat nyt ilmaiseksi kolme kuukautta Stadia Pro -tilausta" />
								<div class="info">
									<time datetime="2022-08-04T15:07:49Z" class="timeago published">4. August, 2022 18:07</time>
									
								</div>
								<div class="curtain"></div>
								<h3>LG:n television omistajat saavat nyt ilmaiseksi kolme kuukautta Stadia Pro -tilausta</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/elokuussa-netflixiin-palaavat-sarjat-realitya-ja-kilpailuja-animea-murhadokkaria" title="Elokuussa Netflixiin palaavat sarjat: realitya ja kilpailuja, animea, murhadokkaria,..."></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/i-am-killer-netflix.jpg" alt="Elokuussa Netflixiin palaavat sarjat: realitya ja kilpailuja, animea, murhadokkaria,..." />
								<div class="info">
									<time datetime="2022-08-04T13:15:0Z" class="timeago published">4. August, 2022 16:15</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Elokuussa Netflixiin palaavat sarjat: realitya ja kilpailuja, animea, murhadokkaria,...</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/steam-deck-steamos-3-3" title="Steam Deckin SteamOS päivittyi versioon 3.3 - kolme päivityskanavaa, varoitus ylikuumenemisesta ja muuta"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Steam-Deck-peleja-asennettuna.jpg" alt="Steam Deckin SteamOS päivittyi versioon 3.3 - kolme päivityskanavaa, varoitus ylikuumenemisesta ja muuta" />
								<div class="info">
									<time datetime="2022-08-04T13:07:10Z" class="timeago published">4. August, 2022 16:07</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Steam Deckin SteamOS päivittyi versioon 3.3 - kolme päivityskanavaa, varoitus ylikuumenemisesta ja muuta</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/04/stt-verkkohyokkays-kiristyshaittaohjelma-lv" title="STT:hen kohdistunut verkkohyökkäys toteutettiin kiristyshaittaohjelmalla"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Cyber-crime-hacking-laptop.jpg" alt="STT:hen kohdistunut verkkohyökkäys toteutettiin kiristyshaittaohjelmalla" />
								<div class="info">
									<time datetime="2022-08-04T12:04:10Z" class="timeago published">4. August, 2022 15:04</time>
									
								</div>
								<div class="curtain"></div>
								<h3>STT:hen kohdistunut verkkohyökkäys toteutettiin kiristyshaittaohjelmalla</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/03/insta360-link-web-kamera-tekoaly-liikkeenseuranta-hinta" title="Insta360:n monipuolinen Link 4K-webkamera käyttää tekoälyä liikkeenseurantaan"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Insta360-Link.jpg" alt="Insta360:n monipuolinen Link 4K-webkamera käyttää tekoälyä liikkeenseurantaan" />
								<div class="info">
									<time datetime="2022-08-03T12:26:42Z" class="timeago published">3. August, 2022 15:26</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Insta360:n monipuolinen Link 4K-webkamera käyttää tekoälyä liikkeenseurantaan</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/03/tassa-kaikki-elokuun-uudet-netflix-sarjat" title="Tässä kaikki elokuun uudet Netflix-sarjat"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/the-sandman-netflix.jpg" alt="Tässä kaikki elokuun uudet Netflix-sarjat" />
								<div class="info">
									<time datetime="2022-08-03T11:10:0Z" class="timeago published">3. August, 2022 14:10</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Tässä kaikki elokuun uudet Netflix-sarjat</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/02/kaikki-elokuun-uudet-netflix-elokuvat-jamie-foxx-ja-snoop-dogg-vampyyrielokuvassa-mark-wahlberg-ja-kevin-hart-komediassa" title="Kaikki elokuun uudet Netflix-elokuvat: Jamie Foxx ja Snoop Dogg vampyyrielokuvassa, Mark Wahlberg ja Kevin Hart komediassa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/day-shift-netflix.jpg" alt="Kaikki elokuun uudet Netflix-elokuvat: Jamie Foxx ja Snoop Dogg vampyyrielokuvassa, Mark Wahlberg ja Kevin Hart komediassa" />
								<div class="info">
									<time datetime="2022-08-02T17:10:14Z" class="timeago published">2. August, 2022 20:10</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Kaikki elokuun uudet Netflix-elokuvat: Jamie Foxx ja Snoop Dogg vampyyrielokuvassa, Mark Wahlberg ja Kevin Hart komediassa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/02/sahkoauto-v2g-varavirta-sahkoverkko" title="Sähköautot tulevat ratkaisemaan tuuli- ja aurinkosähkön ongelmat: Toimivat valtavana akkuvarastona"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/electric-car-charging-station-park.jpg" alt="Sähköautot tulevat ratkaisemaan tuuli- ja aurinkosähkön ongelmat: Toimivat valtavana akkuvarastona" />
								<div class="info">
									<time datetime="2022-08-02T13:11:14Z" class="timeago published">2. August, 2022 16:11</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Sähköautot tulevat ratkaisemaan tuuli- ja aurinkosähkön ongelmat: Toimivat valtavana akkuvarastona</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/02/logitech-g-tencent-yhteistyo-kasikonsoli-pilvipelaaminen" title="Logitech G ja Tencent tuovat markkinoille pilvipelaamiseen tarkoitetun käsikonsolin tämän vuoden aikana"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Tencent-Logitech-G-Logo.jpg" alt="Logitech G ja Tencent tuovat markkinoille pilvipelaamiseen tarkoitetun käsikonsolin tämän vuoden aikana" />
								<div class="info">
									<time datetime="2022-08-02T09:10:13Z" class="timeago published">2. August, 2022 12:10</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Logitech G ja Tencent tuovat markkinoille pilvipelaamiseen tarkoitetun käsikonsolin tämän vuoden aikana</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/08/01/opas-vanha-tietokone-chromebook-chromeos-flex" title="Vanhalle tietokoneelle uusi elämä helposti ja ilmaiseksi: Näin asennetaan uusi ChromeOS Flex lähes mihin tahansa vanhaan Windows- tai Mac-koneeseen"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/chromeos-flex-info.jpg" alt="Vanhalle tietokoneelle uusi elämä helposti ja ilmaiseksi: Näin asennetaan uusi ChromeOS Flex lähes mihin tahansa vanhaan Windows- tai Mac-koneeseen" />
								<div class="info">
									<time datetime="2022-08-01T16:04:8Z" class="timeago published">1. August, 2022 19:04</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Vanhalle tietokoneelle uusi elämä helposti ja ilmaiseksi: Näin asennetaan uusi ChromeOS Flex lähes mihin tahansa vanhaan Windows- tai Mac-koneeseen</h3>
							</li>
						
					</ul>

				</nav>

				<div class="footer">
					<a href="/uutiset/">Laajempi uutislistaus</a>
				</div>
			</aside>
		</div>




	

		<div class="col2">
			<main class="container">
				
<div id="nm-980x400-fb" class="ad-generic"></div>
<div id="nm-300x300-fb" class="mobile-top-ad"></div>

				<article class="article">
					
						<header>
							<h1>Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet</h1>
							

								

								<div class="img-wrap">
									<div class="actions">
										<div class="whatsapp">
											<a href="whatsapp://send" data-text="AfterDawn uutisoi:" data-href="" class="wa_btn wa_btn_s" style="display:none">Jaa</a>
										</div>
										<a class="share-tw" href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">Twiittaa</a>
										<a class="share-fb"href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">Jaa</a>
									</div>
									<picture>
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Huawei-freebuds-pro-2-image-blue.webp" type="image/webp" />
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Huawei-freebuds-pro-2-image-blue.jpg" type="image/jpeg" />
										<img class="header-img" width="1000"  src="https://cdn.afterdawn.fi/news/1000x/Huawei-freebuds-pro-2-image-blue.jpg" alt="Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet" />
									</picture>
									<!-- <img class="header-img-s" src="https://cdn.afterdawn.fi/v3/news/original/wechat-using-iphone.jpg" alt="lorem ipsum" /> -->
									<!-- <div class="video-container"><iframe width="1050" height="591" src="//www.youtube.com/embed/wPUJKtNfxfo?rel=0" frameborder="0" allowfullscreen></iframe></div> -->
								</div>
							
							<div class="author">
								
									<img loading="lazy" class="gravatar" src="https://www.gravatar.com/avatar/334f78320e16eca9f445f740b5d6a674s=30" alt="Janne Yli-Korhonen" width="30" height="30"/>
									<a class="writer" href="/bio/jyk">Janne Yli-Korhonen</a>
									<ul class="some">
										
											<li><a class="icon-twitter" rel="noopener" href="https://twitter.com/yyyykoooo" title="Janne Yli-Korhonen Twitteriss&auml;" target="_blank"></a></li>
										
										<li><a class="icon-email" href="https://keskustelu.afterdawn.com/conversations/add?to=jyk" title="L&auml;het&auml; yksityisviesti" target="_blank"></a></li>
									</ul>
								
								<div class="info">
									<time datetime="2022-08-08T10:44:52Z" class="timeago published">8. August, 2022 13:44</time>
									
								</div>
							</div>
						</header>

						

						<div class="content">
							
							<div class="sharing-bar">
								<!-- Facebook -->
								<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
								</a>

								<!-- Twitter -->
								<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
								</a>
							</div>
							
							<div class="col-center text">
								<p><b>Huawei</b> on tuonut hinnan osalta huippuluokkaan kuuluvat <b>FreeBuds Pro 2</b> -kuulokkeet saataville Suomessa.</p><p>Kuulokkeissa on panostettu äänentoistoon ja taustamelun vähentämiseen.</p><p>Oletuksena kuulokkeissa käytetään yhteistyössä Devialetin kanssa luotua äänitehostetta. Huawein mukaan kuulokkeiden uniikki kaksoisäänentoistojärjestelmä mahdollistaa sekä kirkkaat ja tarkat korkeat äänet että iskevän bassontoiston.</p><p>Triple Adaptive EQ -teknologian ansiosta FreeBuds Pro 2 -kuulokkeet voivat automaattisesti ja reaaliajassa säätää äänentoistoa korvakäytävien rakenteen, käyttöasennon ja äänenvoimakkuuden perusteella.</p><p>Kuulokkeissa hyödynnetään kolmen mikrofonin melunvaimennusjärjestelmää, jonka kerrotaan olevan jopa 15 prosenttia tehokkaampi edeltäjään eli FreeBuds Pro -kuulokkeisiin verrattuna. Kuulokkeiden luvataan tuottavan jopa 47 dB:n vaimennuksen. <br/></p><div class="video"></div>
			<ins class="adsbygoogle"
				 style="display:block; text-align:center;"
				 data-ad-layout="in-article"
				 data-ad-format="fluid"
				 data-ad-client="ca-pub-5626074131133514"
				 data-ad-slot="2169338932"></ins>
			<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
			<p>
		<br/>FreeBuds Pro 2 osaa myös tunnistaa ulkoisen ääniympäristön ja valita sopivimman melunvaimennustilan sen perusteella. Ai Life -sovelluksen kautta voi myös valita itse sopivan tilan.</p><p>Mikrofonien ansiosta myös puheluiden luvataan toimivan selkeästi.</p><p><a href="https://cdn.afterdawn.fi/storage/pictures/1920/Huawei-freebuds-pro-2-image-silver.jpg" target="_blank"><img loading="lazy" src="https://cdn.afterdawn.fi/storage/pictures/800/Huawei-freebuds-pro-2-image-silver.jpg" border="0" alt="hopeat Freebuds pro 2 nappikuulokkeet" /></a></p><p>Huawei FreeBuds Pro 2 -kuulokkeet yhdistyvät saumattomasti kahteen laitteeseen samaan aikaan, mikä mahdollistaa yhteyden vaihdon automaattisesti puhelun tullessa. Kuulokkeet toimivat Android-, iOS- ja Windows-laitteiden kanssa.</p><p>Melunvaimennuksen kanssa kuulokkeet tarjoavat 4 tuntia soittoaikaa ja yhteensä kotelon kanssa jopa 30 tunnin ajaksi. Kotelossa on USB-C -liitäntä ja se tukee myös langatonta latausta. Kuulokkeissa on IP54-luokitus.</p><p>Huawei FreeBuds Pro 2 -kuulokkeet ovat nyt myynnissä Suomessa <a href="https://hintaopas.fi/product.php?p=6656191&ref=61553" target="_blank" rel="sponsored">suositushintaan 199 €</a>. Tuote on saatavilla kolmena värivaihtoehtona: keraaminen valkoinen, huurteinen hopea ja hopeansininen.</p><p><i>Tämä artikkeli sisältää yhteistyökumppaneiden linkkejä. Tuotteen hinta ei muutu, mutta saamme mahdollisesti siitä pienen komission.</i></p>
								
								
									
										<ul class="tags">
											
												<li><a href="/t/huawei" title="Kaikki uutiset aiheesta Huawei">Huawei</a></li>
											
												<li><a href="/t/huawei_freebuds_pro_2" title="Kaikki uutiset aiheesta Huawei FreeBuds Pro 2">Huawei FreeBuds Pro 2</a></li>
											
												<li><a href="/t/kuulokkeet" title="Kaikki uutiset aiheesta kuulokkeet">kuulokkeet</a></li>
											
												<li><a href="/t/hinta" title="Kaikki uutiset aiheesta hinta">hinta</a></li>
											
										</ul>
									
								

								<!--added sharing bar-->
								<div class="sharing-bottom">
									<!-- Facebook -->
									<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Twitter -->
									<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
									</a>

									<!-- Whatsapp -->
									<a class="wtsp-share" href="https://wa.me/?text=https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/whatsapp.png" alt="Jaa Whatsappissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Sharing icon -->
									<a class="gnrc-share" href="#" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/share-icon.png" alt="" width="35" height="35" loading="lazy" id="btn" />
									</a>
								</div>
								<!--added sharing bar end-->
								
								<script>
									const btn = document.getElementById("btn");

									// function for web share api
									function webShareAPI(header, description, link) {
									  navigator
										.share({
										  title: header,
										  text: description,
										  url: link
										})
										.then(() => console.log("Successful share"))
										.catch((error) => console.log("Error sharing", error));
									}

									if (navigator.share) {
									  // Show button if it supports webShareAPI
									  btn.style.display = "block";
									  btn.addEventListener("click", () =>
										webShareAPI("Huawei toi myyntiin 199 euron FreeBuds Pro 2 -kuulokkeet", "Huawei on tuonut hinnan osalta huippuluokkaan kuuluvat FreeBuds Pro 2 -kuulokkeet saataville Suomessa. Kuulokkeissa on panostettu äänentoistoon ja taustamelun vähentämiseen.", "https://fin.afterdawn.com/uutiset/2022/08/08/huawei-freebuds-pro-2-kuulokkeet-hinta")
									  );
									} else {
									  // Hide button if it supports webShareAPI
									  btn.style.display = "none";
									  console.error("Your Browser doesn't support Web Share API");
									}
								</script>

							</div>
							<div id="nm-468x400-300x300" style="margin-bottom:20px;"></div>
							<!-- Tag for Afterdawn.com - Afterdawn_1x1_Adnami_Mid placement -->
							<script data-adfscript="adx.adform.net/adx/?mid=1498693"></script>
							<script src="//s1.adform.net/banners/scripts/adx.js" async defer></script>
						</div>
					

					
					
					
					
					
					<section class="comment-area" id="kommentit">
						<div class="col-center">
							<div class="title-sub">
								
									<h4>KOMMENTOI</h4>
									<div class="source comment-dark"></div>
								
							</div>
							



							
								
									<div class="logintocomment">
										<p style="font-size: 18px;">
											Haluatko kommentoida t&auml;t&auml; artikkelia?<br/>
											<a href="https://kirjaudu.afterdawn.com/login.cfm?returnURL=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F08%2F08%2Fhuawei%2Dfreebuds%2Dpro%2D2%2Dkuulokkeet%2Dhinta%23kommentoi">Kirjaudu sis&auml;&auml;n</a> tai <a href="https://kirjaudu.afterdawn.com/create_new_account.cfm?redirect=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F08%2F08%2Fhuawei%2Dfreebuds%2Dpro%2D2%2Dkuulokkeet%2Dhinta%23kommentoi">Luo uusi k&auml;ytt&auml;j&auml;tunnus</a>.
										</p>
									</div>
								
							
						</div>
					</section>

					

				</article>

				<div class="recommendationElement post">
					<script src="https://widget.high.fi/loadRecommendations.js?v=20180601-01"></script>
				</div>

				

			</main>
		</div>
	
	
		
		
			<footer class="footer">
				<div class="footer-columns">
					<div class="footer-column">
						<div class="footer-logo">
							<a href="https://fin.afterdawn.com/">
								<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" width=251 height=88 style="height:auto;" loading="lazy" alt="AfterDawnin logo">
							</a>
						</div>
						<ul>
							<li><a href="https://fin.afterdawn.com/general/company.cfm">Tietoja meist&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/mainosta">Mainonta</a></li>
							<li><a href="https://fin.afterdawn.com/palaute">Ota yhteytt&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/general/saannot.cfm">K&auml;ytt&ouml;ehdot ja tietoa yksityisyydensuojasta</a></li>
							<li><a href="https://fin.afterdawn.com/general/rekisteriseloste.cfm">Tietosuojaseloste</a></li>
						</ul>
						<div class="footer-logo">
							<a href="https://upcloud.com/signup/?promo=afterdawn" target="_blank" rel="sponsored">
								Yhteydet tarjoaa:<br/>
								<img src="https://cdn.afterdawn.fi/logos/upcloud_logo_horizontal_white_40px.png" width="166" height="45" style="height:auto; margin-left:auto; margin-right:auto;" loading="lazy" alt="UpCloudin logo">
							</a>
						</div>
					</div>
					<div class="footer-column">
						<h4>Osiot:</h4>
						<ul>
							<li><a href="https://fin.afterdawn.com/uutiset/">Uutiset</a></li>
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
							<li><a href="https://fin.afterdawn.com/paivan-diili">P&auml;iv&auml;n diili</a></li>
							<li><a href="https://www.download.fi/">Ohjelmien lataukset</a></li>
							<li><a href="https://www.puhelinvertailu.com/">Mobiilialan uutiset</a></li>
							<li><a href="https://www.puhelinvertailu.com/puhelimet">K&auml;nnyk&ouml;iden tiedot ja vertailu</a></li>
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						</ul>
					</div>
					<div class="footer-column">
						<h4>Seuraa meit&auml;:</h4>
						<ul>
							<li><a href="https://www.facebook.com/afterdawnfi">Facebook</a></li>
							<li><a href="https://twitter.com/afterdawnfi">Twitter</a></li>
							<li><a href="https://www.instagram.com/afterdawnfi/">Instagram</a></li>
							<li><a href="https://www.tiktok.com/@afterdawnfi">TikTok</a></li>
							<li><a href="http://feeds.afterdawn.com/afterdawn_uutiset">RSS-sy&ouml;te</a></li>
							<li><h4 style="padding-top: 0;">Osallistu:</h4></li>
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
							<li><a href="https://x2.fi/">Kysy/Vastaa</a></li>
						</ul>
					</div>
				</div>
				<div class="copyright">
					<div class="copyright-date">&copy; 1999-2022</div>
					<div>
						<a class="copyright-link" href="https://fin.afterdawn.com/">AfterDawn Oy</a>
					</div>
				</div>
			</footer>
		
		

	</div>
	<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
	
		<script type="text/javascript" src="https://cdn.afterdawn.fi/min/f=/scripts/jquery.timeago.js&amp;20201208"></script>
		<script type="text/javascript" src="https://cdn.afterdawn.fi/js/3rd/jquery/locales/jquery.timeago.fi.utf8.js"></script>
	

	<script type="text/javascript">
		$(document).ready(function(){
		  $(".toggle1").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle2, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle2").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle3").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle2").removeClass( "show-onclick" );
		  });
		  $(".search").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		  });

			//burger menu open
			$(".header-burger").click(function () {
				$(".mobile-dropdown").addClass("active");
			});
			//burger menu close
			$(".mobile-dropdown_close").click(function () {
				$(".mobile-dropdown").removeClass("active");
			});

		});

	</script>

	
		
		<script type="text/javascript">
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", $this.outerHeight());
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 190;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '200px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: to - data.parentTop + data.pad.top
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".sharing-bar").pin({containerSelector: ".content"})
		</script>
		
	
	<script type="text/javascript">
		// sidebar fixed
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						var outerHeight = $this.outerHeight();
						var containerHeight = $container.outerHeight();

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", outerHeight);

						// Limit element height on shurt pages
						if (outerHeight > containerHeight) {
							$this.css({height: containerHeight});
							disabled = true; // Disable onScroll
						}
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 120;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '160px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: (to - data.parentTop + data.pad.top) - 120
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".pinned").pin({containerSelector: ".pin-container"})
	</script>
	

	

	<!-- Tapetin kanssa k&auml;ytett&auml;v&auml; js, pit&auml;&auml; eritell&auml; menun paikka -->
	
	<script type="text/javascript">
		jQuery(document).ready(function() {
		  jQuery("time.timeago").timeago();
		});
	</script>
</body>
</html>

