
	
	

	

	
	

	



<!doctype html>
<html lang="fi">
<head>

	<meta charset="UTF-8">

	<link rel="preconnect" href="https://cdn.afterdawn.fi" crossorigin />

	

	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Courgette&display=swap" />

	<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Courgette&display=swap' rel="stylesheet" media="print" onload="this.media='all'">

	<noscript>
		<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=swap' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=swap' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Courgette&display=swap' rel="stylesheet" />
	</noscript>

	

	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=1.0, user-scalable=1" />
	<meta name="HandheldFriendly" content="true">

	<meta name="theme-color" content="#004659">
	
	

		

		<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
		<script>
		  var OneSignal = OneSignal || [];
			OneSignal.push(["init", {
			  appId: "93d08ca6-cfa1-4d6c-a9e9-6494a1c27602",
			}]);
		</script>
		
		

		<!-- Global site tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2099875-2"></script>
		<script>
		  window.dataLayer = window.dataLayer || [];
		  function gtag(){dataLayer.push(arguments);}
		  gtag('js', new Date());

		  gtag('config', 'UA-2099875-2');
		</script>

	

	
		<title>Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui - AfterDawn</title>
		
			<meta name="author" content="Petteri Pyyny">
		
		<link rel="shortcut icon" href="https://cdn.afterdawn.fi/v4/favicon.ico">
		<meta http-equiv="Content-Language" content="fi" />
		
			
				
		
			
			
				
				<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="canonical" href="https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui"> <link rel="amphtml" href="https://fin.afterdawn.com/amp/uutiset/2022/07/02/stranger-things-4-netflix-kaatui"> 
					<meta name="news_keywords" content="Netflix,Stranger Things" />
		<meta name="robots" content="max-image-preview:large">
				<script type="application/ld+json">
				{
				  "@context": "https://schema.org",
				  "@type": "BreadcrumbList",
				  "itemListElement": [{
					"@type": "ListItem",
					"position": 1,
					"name": "Uutiset",
					"item": "https://fin.afterdawn.com/uutiset/"
				  },{
					"@type": "ListItem",
					"position": 2,
					"name": "Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui",
					"item": "https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui"
				  }]
				}
				</script>
			
		
			<script type="application/ld+json">
			{
			"@context": "https://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": "https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui",
			"headline": "Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui",
			"datePublished": "July, 02 2022 09:09:37 +0000",
			"dateModified": "July, 02 2022 09:09:37 +0000",

			
				"description": "Stranger Thingsin neljännen kauden viimeisten jaksojen julkaisu kaatoi Netflixin palvelun.",
			

			
				"author": {
					"@type": "Person",
					"name": "Petteri Pyyny",
					"url": "https://fin.afterdawn.com/bio/drd"
				},
			

			"publisher": {
			  "@type": "Organization",
			  "name": "AfterDawn",
			  "logo": {
				"@type": "ImageObject",
				"url": "https://cdn.afterdawn.fi/storage/pictures/afterdawn-logo-181x60.jpg",
				"width": 181,
				"height": 60
			  }
			}

			
				,
				"image": [
				  "https://cdn.afterdawn.fi/v3/news/original/stranger-things-season-4-volumet-2.jpg",
				  "https://cdn.afterdawn.fi/v3/news/600x400/stranger-things-season-4-volumet-2.jpg"
				]
			

				}
			</script>

		
	
		<meta property="og:title" content="Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui">
		<meta property="og:type" content="article">
		<meta property="og:url" content="https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui">
		<meta property="og:image" content="https://cdn.afterdawn.fi/v3/news/original/stranger-things-season-4-volumet-2.jpg">
		<meta property="og:site_name" content="AfterDawn">
		<meta property="fb:app_id" content="121480884529558" />
	
				<meta name="twitter:card" content="summary_large_image">
				<meta name="twitter:site" content="@afterdawnfi">
				
					<meta name="twitter:creator" content="@pyyny">
				
				<meta name="twitter:title" content="Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui">
				
					<meta name="twitter:description" content="Stranger Thingsin neljännen kauden viimeisten jaksojen julkaisu kaatoi Netflixin palvelun.">
				
				<meta name="twitter:image:src" content="https://cdn.afterdawn.fi/v3/news/600x400/stranger%2Dthings%2Dseason%2D4%2Dvolumet%2D2%2Ejpg">
			
		
		<meta name="description" content="Stranger Thingsin neljännen kauden viimeisten jaksojen julkaisu kaatoi Netflixin palvelun." />
		<link rel="apple-touch-icon" href="https://cdn.afterdawn.fi/v3/apple-touch-icon.png">

		

		

		
			<link rel="alternate" type="application/rss+xml" href="http://feeds.afterdawn.com/afterdawn" title="AfterDawn: News" />
		
		
		

		

	
	
	
	
	

	

	<script>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</script>



	
		
			<link rel="preload" href="https://fin.afterdawn.com/css/styles.css?20220621-01" as="style">
			<link rel="stylesheet" href="https://fin.afterdawn.com/css/styles.css?20220621-01">
		
	

	
	<script async='async' src='https://lwadm.com/lw/pbjs?pid=c4dda897-addc-4dd5-8d32-7eea81901c87'></script>
	<script type='text/javascript'>
		var lwhbim = lwhbim || {cmd:[]};
	</script>
	
</head>
<body>

	<header class="no-max-width header">
		
			<div class="sites">
				
					<ul class="menu-sites">
						<li><a href="https://fin.afterdawn.com/">AfterDawn</a></li>
						<li><a href="https://www.puhelinvertailu.com/">Puhelinvertailu</a></li>
						<li><a href="https://www.hardware.fi/">Hardware.fi</a></li>
						<li><a href="https://www.download.fi/">download.fi</a></li>
						<li><a href="https://x2.fi/">X2.fi</a></li>
						<li><a href="https://high.fi/">HIGH.FI</a></li>
					</ul>
				
				
				
				<div class="login-dropdown not-logged-in">
					<img class="user-logo" src="https://cdn.afterdawn.fi/x2fi/responsive/img/person-icon.png" alt="User img">
					<div class="login-dropdown_panel">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a><br/>
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
				</div>
				
			</div>
			
		
		
		<div class="max-width">

			
			<div class="header-burger">
				<div></div>
				<div></div>
				<div></div>
			</div>
			
			
			

				
			
				<div class="mobile-dropdown">
					<div class="mobile-dropdown_close">
						<div></div>
						<div></div>
					</div>
					<ul class="mobile-dropdown_menu">
						<li><a href="https://fin.afterdawn.com/" class="dropdown-link">Etusivu</a></li>
						<li><a href="https://fin.afterdawn.com/uutiset/" class="dropdown-link">Uutiset</a></li>
						<li><a href="https://fin.afterdawn.com/arvostelut/" class="dropdown-link">Arvostelut</a></li>
						<li><a href="https://fin.afterdawn.com/oppaat/" class="dropdown-link">Oppaat</a></li>
						<li><a href="https://fin.afterdawn.com/paivan-diili" class="dropdown-link">Tarjoukset</a></li>
						<li><a href="https://fin.afterdawn.com/parhaat" class="dropdown-link">Parhaat</a></li>
						<li><a href="https://keskustelu.afterdawn.com/" class="dropdown-link">Keskustelu</a></li>
					</ul>
					<div class="mobile-dropdown_panel not-logged-in">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a>
							<a class="dropdown-link register-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
					<div class="mobile-dropdown_social">
						<a class="social-link fb-link" href="https://www.facebook.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link tw-link" href="https://twitter.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link inst-link" href="https://instagram.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
					</div>
				</div>

				

				
				<a href="https://fin.afterdawn.com/" class="branding" title="AfterDawnin Etusivulle">
					<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" alt="AfterDawn logo">
				</a>
				


				<a class="search" href="#"></a>
				<form class="search-form-m" method="get" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm">
					<input type="search" value="" name="q" placeholder="Hae uutisia..." />
					<input type="submit" value="">
				</form>

				<nav>
					<ul class="menu-main">
						
							<li><a href="https://fin.afterdawn.com/">Etusivu</a></li>
						
							<li><a href="https://fin.afterdawn.com/uutiset/" class="active">Uutiset</a></li>
						
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
						
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						
							<li><a href="https://fin.afterdawn.com/paivan-diili">Tarjoukset</a></li>
						
							<li><a href="https://fin.afterdawn.com/parhaat">Parhaat</a></li>
						
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
						
						
						<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb-m" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
						<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter-m" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
					</ul>
				</nav>
				
				<form class="search-form" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm" method="get">
					<input type="search" value="" name="q" placeholder="Hae uutisia...">
					<input type="submit" value="Hae">
				</form>
			
			

			
			<ul class="menu-some">
				<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
				<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
			</ul>
			
			

		</div>
	</header>

	<div class="no-max-width">
		<ul class="max-width menu-tags">
			
			
				
				<li><a href="https://fin.afterdawn.com/t/robotti-imuri">Robotti-imurit</a></li>
				<li><a href="https://fin.afterdawn.com/t/kuulokkeiden_arvostelut">Kuulokkeet</a></li>
				<li><a href="https://fin.afterdawn.com/t/robottiruohonleikkuri">Robottiruohonleikkuri</a></li>
				<li><a href="https://fin.afterdawn.com/t/sahkopotkulauta">S&auml;hk&ouml;potkulaudat</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2021/01/27/paras-naytonohjain">Parhaat n&auml;yt&ouml;nohjaimet</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2021/06/22/paras-bluetooth-kaiutin">Parhaat Bluetooth-kaiuttimet</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2021/02/26/halpa-peli-pc">Rakenna halpa peli-PC</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2020/09/15/opas-kovalevyn-vaihto-tietokoneeseen-ssd-tai-hdd">Opas: Kovalevyn vaihto</a></li>
			
			
			
		</ul>
	</div>
	<div class="max-width">



		<div class="ad-160" id='fin_desktop-160x600'>
		</div>
		<script>
			lwhbim.cmd.push(function() {
				lwhbim.loadAd({tagId: 'fin_desktop-160x600'});
			});
		</script>

		<div class="col1 pin-container">
			<aside class="col1-inner pinned">
				<nav class="menu-sub">

					

					

					

					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/07/01/firefox-102-seuranta-esto" title="Hei hei ?fbclid -sekoilu! Uusi Firefox siivoaa osoitteista mm. Facebookin käyttämät seurantarimpsut"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Firefox-logo-and-wordmark-horizontal-2020.jpg" alt="Hei hei ?fbclid -sekoilu! Uusi Firefox siivoaa osoitteista mm. Facebookin käyttämät seurantarimpsut" />
								<div class="info">
									<time datetime="2022-07-01T15:55:53Z" class="timeago published">1. July, 2022 18:55</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Hei hei ?fbclid -sekoilu! Uusi Firefox siivoaa osoitteista mm. Facebookin käyttämät seurantarimpsut</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/07/01/venaja-uusi-seteli-pankkiautomaatti" title="Venäjä julkaisi uuden setelin - mutta sitä ei voi ottaa käyttöön, koska pankkiautomaatteja ei voi päivittää"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/russian-new-100-rouble-bill.jpg" alt="Venäjä julkaisi uuden setelin - mutta sitä ei voi ottaa käyttöön, koska pankkiautomaatteja ei voi päivittää" />
								<div class="info">
									<time datetime="2022-07-01T15:27:58Z" class="timeago published">1. July, 2022 18:27</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Venäjä julkaisi uuden setelin - mutta sitä ei voi ottaa käyttöön, koska pankkiautomaatteja ei voi päivittää</h3>
							</li>
						
					</ul>

					<div id='fin_desktop-sidebar' class="ad-300"></div>
<script>
    lwhbim.cmd.push(function() {
        lwhbim.loadAd({tagId: 'fin_desktop-sidebar'});
    });
</script>


					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/07/01/samsung-gaming-hub-samsung-2022-televisiot" title="Samsungin Gaming Hub saapuu nyt uusiin televisioihin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Samsung-Gaming-Hub-TV-2.jpg" alt="Samsungin Gaming Hub saapuu nyt uusiin televisioihin" />
								<div class="info">
									<time datetime="2022-07-01T15:01:20Z" class="timeago published">1. July, 2022 18:01</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Samsungin Gaming Hub saapuu nyt uusiin televisioihin</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/30/paras-naytonohjain" title="Listaus: Parhaat näytönohjaimet 2022 - Hinnat vihdoinkin laskemassa, saatavuus paranee"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/amd-radeon-rx-6800-xt.jpg" alt="Listaus: Parhaat näytönohjaimet 2022 - Hinnat vihdoinkin laskemassa, saatavuus paranee" />
								<div class="info">
									<time datetime="2022-06-30T16:59:0Z" class="timeago published">30. June, 2022 19:59</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Listaus: Parhaat näytönohjaimet 2022 - Hinnat vihdoinkin laskemassa, saatavuus paranee</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/30/instagram-syote-ehdotetut-julkaisu-piilottaminen" title="Ärsyttävätkö Instagram-syötteessä näkyvät ehdotetut julkaisut? Näin piilotat ne"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Instagram-ehdotettu-julkaisu.jpg" alt="Ärsyttävätkö Instagram-syötteessä näkyvät ehdotetut julkaisut? Näin piilotat ne" />
								<div class="info">
									<time datetime="2022-06-30T14:41:6Z" class="timeago published">30. June, 2022 17:41</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Ärsyttävätkö Instagram-syötteessä näkyvät ehdotetut julkaisut? Näin piilotat ne</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/30/tcl-4k-hdr-lcd-p635-p638-televisio-hinta" title="TCL tuo myyntiin edullisemman hintaluokan 4K LCD -televisiot"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/TCL-P638-lifestyle.jpg" alt="TCL tuo myyntiin edullisemman hintaluokan 4K LCD -televisiot" />
								<div class="info">
									<time datetime="2022-06-30T13:13:10Z" class="timeago published">30. June, 2022 16:13</time>
									
								</div>
								<div class="curtain"></div>
								<h3>TCL tuo myyntiin edullisemman hintaluokan 4K LCD -televisiot</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/29/return-to-monkey-island-pelista-julkaistiin-ensimmainen-pelivideo-katso" title="Return to Monkey Island -pelistä julkaistiin ensimmäinen pelivideo, katso!"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/return-to-monkey-island-gameplay-screenshot.jpg" alt="Return to Monkey Island -pelistä julkaistiin ensimmäinen pelivideo, katso!" />
								<div class="info">
									<time datetime="2022-06-29T17:24:32Z" class="timeago published">29. June, 2022 20:24</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Return to Monkey Island -pelistä julkaistiin ensimmäinen pelivideo, katso!</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/29/insta360-one-rs-1-inch-360-edition-kamera-julkaisu" title="Insta360 julkaisi monipuolisen ONE RS 1-Inch 360 Edition -kameran"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Insta360-One-RS-1-Inch-360-edition.jpg" alt="Insta360 julkaisi monipuolisen ONE RS 1-Inch 360 Edition -kameran" />
								<div class="info">
									<time datetime="2022-06-29T13:43:4Z" class="timeago published">29. June, 2022 16:43</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Insta360 julkaisi monipuolisen ONE RS 1-Inch 360 Edition -kameran</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/29/dhl-sahkoposti-huijausviesti-paketti-vireilla-keskeytetty-toimitus" title="DHL:n nimissä liikkuu paljon huijausviestejä, jotka kalastelevat henkilö- ja maksutietoja"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/DHL-huijausviesti-2022-kesa.jpg" alt="DHL:n nimissä liikkuu paljon huijausviestejä, jotka kalastelevat henkilö- ja maksutietoja" />
								<div class="info">
									<time datetime="2022-06-29T11:09:28Z" class="timeago published">29. June, 2022 14:09</time>
									
								</div>
								<div class="curtain"></div>
								<h3>DHL:n nimissä liikkuu paljon huijausviestejä, jotka kalastelevat henkilö- ja maksutietoja</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/28/jbl-reflect-aero-kuulokkeet-ip68-luokitus-hinta" title="JBL:n treenaamiseen sopivissa Reflect Aero -nappikuulokkeissa on IP68-luokitus"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/JBL-Reflect-Aero-Lifestyle-White.jpg" alt="JBL:n treenaamiseen sopivissa Reflect Aero -nappikuulokkeissa on IP68-luokitus" />
								<div class="info">
									<time datetime="2022-06-28T14:07:49Z" class="timeago published">28. June, 2022 17:07</time>
									
								</div>
								<div class="curtain"></div>
								<h3>JBL:n treenaamiseen sopivissa Reflect Aero -nappikuulokkeissa on IP68-luokitus</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/28/jbl-live-pro-2-kuulokkeet-hinta" title="JBL toi saataville JBL Live Pro 2 -nappikuulokkeet"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/JBL-Live-Pro-2.jpg" alt="JBL toi saataville JBL Live Pro 2 -nappikuulokkeet" />
								<div class="info">
									<time datetime="2022-06-28T13:23:51Z" class="timeago published">28. June, 2022 16:23</time>
									
								</div>
								<div class="curtain"></div>
								<h3>JBL toi saataville JBL Live Pro 2 -nappikuulokkeet</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/27/microsoft-edge-103-clarity-boost-tehokkuustila" title="Edge-selain kuluttaa nyt vähemmän suoritinta pelatessa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Microsoft-edge-gaming.jpg" alt="Edge-selain kuluttaa nyt vähemmän suoritinta pelatessa" />
								<div class="info">
									<time datetime="2022-06-27T16:26:16Z" class="timeago published">27. June, 2022 19:26</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Edge-selain kuluttaa nyt vähemmän suoritinta pelatessa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/27/chromecast-ilman-wifi" title="Uudessa Chromecastissa erinomainen parannus aiempaan: kännykän netti riittää"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Chromecast-with-Google-TV-Lifestyle.jpg" alt="Uudessa Chromecastissa erinomainen parannus aiempaan: kännykän netti riittää" />
								<div class="info">
									<time datetime="2022-06-27T15:46:45Z" class="timeago published">27. June, 2022 18:46</time>
									<a class="comments" href="#">2</a>
								</div>
								<div class="curtain"></div>
								<h3>Uudessa Chromecastissa erinomainen parannus aiempaan: kännykän netti riittää</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/27/afterdawnin-ulkoasu-uudistui-ensimmaista-kertaa-sitten-vuoden-2009" title="AfterDawnin ulkoasu uudistui, ensimmäistä kertaa sitten vuoden 2009"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/afterdawn_logo_hires_whitebg-1280x720.jpg" alt="AfterDawnin ulkoasu uudistui, ensimmäistä kertaa sitten vuoden 2009" />
								<div class="info">
									<time datetime="2022-06-27T15:19:17Z" class="timeago published">27. June, 2022 18:19</time>
									<a class="comments" href="#">8</a>
								</div>
								<div class="curtain"></div>
								<h3>AfterDawnin ulkoasu uudistui, ensimmäistä kertaa sitten vuoden 2009</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/26/paivan-diili-roomba-i3-vain-129-euroa" title="Päivän diili: 4,5 tähteä arvostelussamme napannut Roomba i3 vain 129 euroa!"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/roomba-i3-arvostelu.jpg" alt="Päivän diili: 4,5 tähteä arvostelussamme napannut Roomba i3 vain 129 euroa!" />
								<div class="info">
									<time datetime="2022-06-26T18:18:41Z" class="timeago published">26. June, 2022 21:18</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Päivän diili: 4,5 tähteä arvostelussamme napannut Roomba i3 vain 129 euroa!</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/06/26/google-analytics-laiton-italia-eu" title="Google Analytics todettiin jälleen laittomaksi EU:ssa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/google-analytics-logo.jpg" alt="Google Analytics todettiin jälleen laittomaksi EU:ssa" />
								<div class="info">
									<time datetime="2022-06-26T17:59:36Z" class="timeago published">26. June, 2022 20:59</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Google Analytics todettiin jälleen laittomaksi EU:ssa</h3>
							</li>
						
					</ul>

				</nav>

				<div class="footer">
					<a href="/uutiset/">Laajempi uutislistaus</a>
				</div>
			</aside>
		</div>




	

		<div class="col2">
			<main class="container">
				
<div id='fin_desktop-top' class="ad-generic"></div>
<div id='fin_mobile-top' class="mobile-top-ad"></div>
<script>
	var isMobile = (window.innerWidth ||
	document.documentElement.clientWidth ||
	document.body.clientWidth) < 1000;
	lwhbim.cmd.push(function() {
	lwhbim.loadAd({tagId: isMobile ? 'fin_mobile-top' : 'fin_desktop-top'});
	});
</script>

				<article class="article">
					
						<header>
							<h1>Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui</h1>
							

								

								<div class="img-wrap">
									<div class="actions">
										<div class="whatsapp">
											<a href="whatsapp://send" data-text="AfterDawn uutisoi:" data-href="" class="wa_btn wa_btn_s" style="display:none">Jaa</a>
										</div>
										<a class="share-tw" href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">Twiittaa</a>
										<a class="share-fb"href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">Jaa</a>
									</div>
									<picture>
										<source srcset="https://cdn.afterdawn.fi/news/1000x/stranger-things-season-4-volumet-2.webp" type="image/webp" />
										<source srcset="https://cdn.afterdawn.fi/news/1000x/stranger-things-season-4-volumet-2.jpg" type="image/jpeg" />
										<img class="header-img" width="1000"  height="500" src="https://cdn.afterdawn.fi/news/1000x/stranger-things-season-4-volumet-2.jpg" alt="Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui" />
									</picture>
									<!-- <img class="header-img-s" src="https://cdn.afterdawn.fi/v3/news/original/wechat-using-iphone.jpg" alt="lorem ipsum" /> -->
									<!-- <div class="video-container"><iframe width="1050" height="591" src="//www.youtube.com/embed/wPUJKtNfxfo?rel=0" frameborder="0" allowfullscreen></iframe></div> -->
								</div>
							
							<div class="author">
								
									<img loading="lazy" class="gravatar" src="https://www.gravatar.com/avatar/ee900139e12ace0c78ca07b27304fe47s=30" alt="Petteri Pyyny" width="30" height="30"/>
									<a class="writer" href="/bio/drd">Petteri Pyyny</a>
									<ul class="some">
										
											<li><a class="icon-twitter" rel="noopener" href="https://twitter.com/pyyny" title="Petteri Pyyny Twitteriss&auml;" target="_blank"></a></li>
										
										<li><a class="icon-email" href="https://keskustelu.afterdawn.com/conversations/add?to=drd" title="L&auml;het&auml; yksityisviesti" target="_blank"></a></li>
									</ul>
								
								<div class="info">
									<time datetime="2022-07-02T09:09:37Z" class="timeago published">2. July, 2022 12:09</time>
									
								</div>
							</div>
						</header>

						

						<div class="content">
							
							<div class="sharing-bar">
								<!-- Facebook -->
								<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
								</a>

								<!-- Twitter -->
								<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
								</a>
							</div>
							
							<div class="col-center text">
								<p>Kulttisarjaksi muodostuneen <strong><i>Stranger Thingsin</i></strong> neljännen kauden viimeiset jaksot julkaistiin maailmanlaajuisesti eilen. Julkaisu tapahtui samalla hetkellä koko maailmassa, Suomen aikaa kymmeneltä aamulla. Ja se oli ilmeisesti liikaa <strong>Netflixin</strong> järjestelmälle.</p><p>Käytännössä sillä sekunnilla, kun Stranger Thingsin neljännen kauden kaksi viimeistä jaksoa julkaistiin, Netflix kaatui.</p><p>Verkkopalveluiden tilaa seuraava <b>DownDetector</b> havaitsi valtavan piikin ongelmissa heti jaksojen julkaisun jälkeen ja myös sosiaalinen media täyttyi vihaisista käyttäjistä.<br/></p><div class="video"></div>
			<ins class="adsbygoogle"
				 style="display:block; text-align:center;"
				 data-ad-layout="in-article"
				 data-ad-format="fluid"
				 data-ad-client="ca-pub-5626074131133514"
				 data-ad-slot="2169338932"></ins>
			<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
			<p>
		<br/><center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">anyones else's netflix crashed? i'm assuming too many ppl online waiting for volume 2&#128557; <a href="https://t.co/ZaiKCWxv6Y">pic.twitter.com/ZaiKCWxv6Y</a></p>-- alyssa (@alyssa64490887) <a href="https://twitter.com/alyssa64490887/status/1542765351972257792?ref_src=twsrc%5Etfw">July 1, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">vecna laughing at us bc netflix crashed <a href="https://twitter.com/hashtag/StrangerThings?src=hash&ref_src=twsrc%5Etfw">#StrangerThings</a> <a href="https://twitter.com/hashtag/Netflix?src=hash&ref_src=twsrc%5Etfw">#Netflix</a> <a href="https://t.co/a3WbOPDFtY">pic.twitter.com/a3WbOPDFtY</a></p>-- delgado (@4ng3La_) <a href="https://twitter.com/4ng3La_/status/1542766868582342656?ref_src=twsrc%5Etfw">July 1, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center></p><p>Lopulta kyse ei onneksi ollut pitkästä odotuksesta, sillä palvelu saatiin rullaamaan jälleen noin 30 minuutin käyttökatkon jälkeen ja fanit pääsivät odottamansa sarjan ääreen.</p><p><center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">me waiting patiently after netflix crashed <a href="https://t.co/YZ7X56vhai">pic.twitter.com/YZ7X56vhai</a></p>-- hejo (@heizdu) <a href="https://twitter.com/heizdu/status/1542767542028369920?ref_src=twsrc%5Etfw">July 1, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center></p><p>Stranger Thingsin neljäs kausi jaettiin kahteen osaan ja kauden kaksi viimeistä superpitkää jaksoa julkaistiin vasta kuukautta muita jaksoja myöhemmin. Alla neljännen kauden toisen osion traileri:<br/></p>
			<ins class="adsbygoogle"
				 style="display:block; text-align:center;"
				 data-ad-layout="in-article"
				 data-ad-format="fluid"
				 data-ad-client="ca-pub-5626074131133514"
				 data-ad-slot="2169338932"></ins>
			<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
			<p>
		<br/><center><section class="video-container"><iframe width="560" height="315" src="https://www.youtube.com/embed/sBEvEcpnG7k" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen loading="lazy"></iframe></section></center></p>
								
								
									
										<ul class="tags">
											
												<li><a href="/t/netflix" title="Kaikki uutiset aiheesta Netflix">Netflix</a></li>
											
												<li><a href="/t/stranger_things" title="Kaikki uutiset aiheesta Stranger Things">Stranger Things</a></li>
											
										</ul>
									
								

								<!--added sharing bar-->
								<div class="sharing-bottom">
									<!-- Facebook -->
									<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Twitter -->
									<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
									</a>

									<!-- Whatsapp -->
									<a class="wtsp-share" href="https://wa.me/?text=https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/whatsapp.png" alt="Jaa Whatsappissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Sharing icon -->
									<a class="gnrc-share" href="#" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/share-icon.png" alt="" width="35" height="35" loading="lazy" id="btn" />
									</a>
								</div>
								<!--added sharing bar end-->
								
								<script>
									const btn = document.getElementById("btn");

									// function for web share api
									function webShareAPI(header, description, link) {
									  navigator
										.share({
										  title: header,
										  text: description,
										  url: link
										})
										.then(() => console.log("Successful share"))
										.catch((error) => console.log("Error sharing", error));
									}

									if (navigator.share) {
									  // Show button if it supports webShareAPI
									  btn.style.display = "block";
									  btn.addEventListener("click", () =>
										webShareAPI("Siihen vaadittiin Stranger Thingsin viimeisten jaksojen julkaisu: Netflix kaatui", "Stranger Thingsin neljännen kauden viimeisten jaksojen julkaisu kaatoi Netflixin palvelun.", "https://fin.afterdawn.com/uutiset/2022/07/02/stranger-things-4-netflix-kaatui")
									  );
									} else {
									  // Hide button if it supports webShareAPI
									  btn.style.display = "none";
									  console.error("Your Browser doesn't support Web Share API");
									  document.write("Your Browser doesn't support Web Share API");
									}
								</script>

							</div>
						</div>
					

					
					
					
					
					
					<section class="comment-area" id="kommentit">
						<div class="col-center">
							<div class="title-sub">
								
									<h4>KOMMENTOI</h4>
									<div class="source comment-dark"></div>
								
							</div>
							



							
								
									<div class="logintocomment">
										<p style="font-size: 18px;">
											Haluatko kommentoida t&auml;t&auml; artikkelia?<br/>
											<a href="https://kirjaudu.afterdawn.com/login.cfm?returnURL=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F07%2F02%2Fstranger%2Dthings%2D4%2Dnetflix%2Dkaatui%23kommentoi">Kirjaudu sis&auml;&auml;n</a> tai <a href="https://kirjaudu.afterdawn.com/create_new_account.cfm?redirect=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F07%2F02%2Fstranger%2Dthings%2D4%2Dnetflix%2Dkaatui%23kommentoi">Luo uusi k&auml;ytt&auml;j&auml;tunnus</a>.
										</p>
									</div>
								
							
						</div>
					</section>

					

				</article>

				<div class="recommendationElement post">
					<script src="https://widget.high.fi/loadRecommendations.js?v=20180601-01"></script>
				</div>

				

			</main>
		</div>
	
	
		
		
			<footer class="footer">
				<div class="footer-columns">
					<div class="footer-column">
						<div class="footer-logo">
							<a href="https://fin.afterdawn.com/">
								<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" width=251 height=88 style="height:auto;" loading="lazy" alt="AfterDawnin logo">
							</a>
						</div>
						<ul>
							<li><a href="https://fin.afterdawn.com/general/company.cfm">Tietoja meist&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/mainosta">Mainonta</a></li>
							<li><a href="https://fin.afterdawn.com/palaute">Ota yhteytt&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/general/saannot.cfm">K&auml;ytt&ouml;ehdot ja tietoa yksityisyydensuojasta</a></li>
							<li><a href="https://fin.afterdawn.com/general/rekisteriseloste.cfm">Tietosuojaseloste</a></li>
						</ul>
						<div class="footer-logo">
							<a href="https://upcloud.com/signup/?promo=afterdawn" target="_blank" rel="sponsored">
								Yhteydet tarjoaa:<br/>
								<img src="https://cdn.afterdawn.fi/logos/upcloud_logo_horizontal_white_40px.png" width="166" height="45" style="height:auto; margin-left:auto; margin-right:auto;" loading="lazy" alt="UpCloudin logo">
							</a>
						</div>
					</div>
					<div class="footer-column">
						<h4>Osiot:</h4>
						<ul>
							<li><a href="https://fin.afterdawn.com/uutiset/">Uutiset</a></li>
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
							<li><a href="https://fin.afterdawn.com/paivan-diili">P&auml;iv&auml;n diili</a></li>
							<li><a href="https://www.download.fi/">Ohjelmien lataukset</a></li>
							<li><a href="https://www.puhelinvertailu.com/">Mobiilialan uutiset</a></li>
							<li><a href="https://www.puhelinvertailu.com/puhelimet">K&auml;nnyk&ouml;iden tiedot ja vertailu</a></li>
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						</ul>
					</div>
					<div class="footer-column">
						<h4>Seuraa meit&auml;:</h4>
						<ul>
							<li><a href="https://www.facebook.com/afterdawnfi">Facebook</a></li>
							<li><a href="https://twitter.com/afterdawnfi">Twitter</a></li>
							<li><a href="https://www.instagram.com/afterdawnfi/">Instagram</a></li>
							<li><a href="https://www.tiktok.com/@afterdawnfi">TikTok</a></li>
							<li><a href="http://feeds.afterdawn.com/afterdawn_uutiset">RSS-sy&ouml;te</a></li>
							<li><h4 style="padding-top: 0;">Osallistu:</h4></li>
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
							<li><a href="https://x2.fi/">Kysy/Vastaa</a></li>
						</ul>
					</div>
				</div>
				<div class="copyright">
					<div class="copyright-date">&copy; 1999-2022</div>
					<div>
						<a class="copyright-link" href="https://fin.afterdawn.com/">AfterDawn Oy</a>
					</div>
				</div>
			</footer>
		
		

	</div>
	<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
	
		<script type="text/javascript" src="https://cdn.afterdawn.fi/min/f=/scripts/jquery.timeago.js&amp;20201208"></script>
		<script type="text/javascript" src="https://cdn.afterdawn.fi/js/3rd/jquery/locales/jquery.timeago.fi.utf8.js"></script>
	

	<script type="text/javascript">
		$(document).ready(function(){
		  $(".toggle1").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle2, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle2").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle3").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle2").removeClass( "show-onclick" );
		  });
		  $(".search").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		  });

			//burger menu open
			$(".header-burger").click(function () {
				$(".mobile-dropdown").addClass("active");
			});
			//burger menu close
			$(".mobile-dropdown_close").click(function () {
				$(".mobile-dropdown").removeClass("active");
			});

		});

	</script>

	
		
		<script type="text/javascript">
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", $this.outerHeight());
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 190;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '200px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: to - data.parentTop + data.pad.top
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".sharing-bar").pin({containerSelector: ".content"})
		</script>
		
	
	<script type="text/javascript">
		// sidebar fixed
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						var outerHeight = $this.outerHeight();
						var containerHeight = $container.outerHeight();

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", outerHeight);

						// Limit element height on shurt pages
						if (outerHeight > containerHeight) {
							$this.css({height: containerHeight});
							disabled = true; // Disable onScroll
						}
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 120;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '160px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: (to - data.parentTop + data.pad.top) - 120
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".pinned").pin({containerSelector: ".pin-container"})
	</script>
	

	

	<!-- Tapetin kanssa k&auml;ytett&auml;v&auml; js, pit&auml;&auml; eritell&auml; menun paikka -->
	
	<script type="text/javascript">
		jQuery(document).ready(function() {
		  jQuery("time.timeago").timeago();
		});
	</script>
</body>
</html>

