
	
	

	

	
	

	



<!doctype html>
<html lang="fi">
<head>

	<meta charset="UTF-8">

	<link rel="preconnect" href="https://cdn.afterdawn.fi" crossorigin />

	
	

	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" />

	<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback' rel="stylesheet" media="print" onload="this.media='all'">
	<link href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" rel="stylesheet" media="print" onload="this.media='all'">

	<noscript>
		<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback' rel="stylesheet" />
		<link href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" rel="stylesheet" />
	</noscript>

	

	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=1.0, user-scalable=1" />
	<meta name="HandheldFriendly" content="true">

	<meta name="theme-color" content="#004659">
	
	

		

		<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
		<script>
		  var OneSignal = OneSignal || [];
			OneSignal.push(["init", {
			  appId: "93d08ca6-cfa1-4d6c-a9e9-6494a1c27602",
			}]);
		</script>
		
		

		<!-- Global site tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2099875-2"></script>
		<script>
		  window.dataLayer = window.dataLayer || [];
		  function gtag(){dataLayer.push(arguments);}
		  gtag('js', new Date());

		  gtag('config', 'UA-2099875-2');
		</script>

	

	
		<title>Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa - AfterDawn</title>
		
			<meta name="author" content="Janne Yli-Korhonen">
		
		<link rel="shortcut icon" href="https://cdn.afterdawn.fi/v4/favicon.ico">
		<meta http-equiv="Content-Language" content="fi" />
		
			
				
		
			
			
				
				<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="canonical" href="https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022"> <link rel="amphtml" href="https://fin.afterdawn.com/amp/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022"> 
					<meta name="news_keywords" content="Check Point,haittaohjelma,Emotet,tietoturva" />
		<meta name="robots" content="max-image-preview:large">
				<script type="application/ld+json">
				{
				  "@context": "https://schema.org",
				  "@type": "BreadcrumbList",
				  "itemListElement": [{
					"@type": "ListItem",
					"position": 1,
					"name": "Uutiset",
					"item": "https://fin.afterdawn.com/uutiset/"
				  },{
					"@type": "ListItem",
					"position": 2,
					"name": "Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa",
					"item": "https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022"
				  }]
				}
				</script>
			
		
			<script type="application/ld+json">
			{
			"@context": "https://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": "https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022",
			"headline": "Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa",
			"datePublished": "December, 14 2022 12:24:48 +0000",
			"dateModified": "December, 14 2022 12:24:48 +0000",

			
				"description": "Sekä maailmalla että Suomessa kärjessä on AgentTesla, joka keräilee kaikessa hiljaisuudessa uhrin tietoja, kuten salasanoja.",
			

			
				"author": {
					"@type": "Person",
					"name": "Janne Yli-Korhonen",
					"url": "https://fin.afterdawn.com/bio/jyk"
				},
			

			"publisher": {
			  "@type": "Organization",
			  "name": "AfterDawn",
			  "logo": {
				"@type": "ImageObject",
				"url": "https://cdn.afterdawn.fi/storage/pictures/afterdawn-logo-181x60.jpg",
				"width": 181,
				"height": 60
			  }
			}

			
				,
				"image": [
				  "https://cdn.afterdawn.fi/v3/news/original/Laptop-11101001-pexels.jpg",
				  "https://cdn.afterdawn.fi/v3/news/600x400/Laptop-11101001-pexels.jpg"
				]
			

				}
			</script>

		
	
		<meta property="og:title" content="Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa">
		<meta property="og:type" content="article">
		<meta property="og:url" content="https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022">
		<meta property="og:image" content="https://cdn.afterdawn.fi/v3/news/original/Laptop-11101001-pexels.jpg">
		<meta property="og:site_name" content="AfterDawn">
		<meta property="fb:app_id" content="121480884529558" />
	
				<meta name="twitter:card" content="summary_large_image">
				<meta name="twitter:site" content="@afterdawnfi">
				
					<meta name="twitter:creator" content="@yyyykoooo">
				
				<meta name="twitter:title" content="Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa">
				
					<meta name="twitter:description" content="Sekä maailmalla että Suomessa kärjessä on AgentTesla, joka keräilee kaikessa hiljaisuudessa uhrin tietoja, kuten salasanoja.">
				
				<meta name="twitter:image:src" content="https://cdn.afterdawn.fi/v3/news/600x400/Laptop%2D11101001%2Dpexels%2Ejpg">
			
		
		<meta name="description" content="Sekä maailmalla että Suomessa kärjessä on AgentTesla, joka keräilee kaikessa hiljaisuudessa uhrin tietoja, kuten salasanoja." />
		<link rel="apple-touch-icon" href="https://cdn.afterdawn.fi/v3/apple-touch-icon.png">

		

		

		
			<link rel="alternate" type="application/rss+xml" href="https://feeds.feedburner.com/afterdawn_uutiset" title="AfterDawnin uutiset" />
		
		
		

		

	
	
	
	
	

	

	<script>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</script>



	
		
			<link rel="preload" href="https://fin.afterdawn.com/css/styles-min.css?20221030-01" as="style">
			<link rel="stylesheet" href="https://fin.afterdawn.com/css/styles-min.css?20221030-01">
		
	

	

	<script async="async" src="https://macro.adnami.io/macro/hosts/adsm.macro.fin.afterdawn.com.js"></script>

	<link rel="preload" href="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" as="script" crossorigin="anonymous">
	<script src="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" crossorigin="anonymous"></script>

	


</head>
<body>

	<header class="no-max-width header">
		
			<div class="sites">
				
					<ul class="menu-sites">
						<li><a href="https://fin.afterdawn.com/">AfterDawn</a></li>
						<li><a href="https://www.puhelinvertailu.com/">Puhelinvertailu</a></li>
						<li><a href="https://www.hardware.fi/">Hardware.fi</a></li>
						<li><a href="https://www.download.fi/">download.fi</a></li>
						<li><a href="https://x2.fi/">X2.fi</a></li>
						<li><a href="https://high.fi/">HIGH.FI</a></li>
					</ul>
				
				
				
				<div class="login-dropdown not-logged-in">
					<img class="user-logo" src="https://cdn.afterdawn.fi/x2fi/responsive/img/person-icon.png" alt="User img">
					<div class="login-dropdown_panel">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a><br/>
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
				</div>
				
			</div>
			
		
		
		<div class="max-width">

			
			<div class="header-burger">
				<div></div>
				<div></div>
				<div></div>
			</div>
			
			
			

				
			
				<div class="mobile-dropdown">
					<div class="mobile-dropdown_close">
						<div></div>
						<div></div>
					</div>
					<ul class="mobile-dropdown_menu">
						<li><a href="https://fin.afterdawn.com/" class="dropdown-link">Etusivu</a></li>
						<li><a href="https://fin.afterdawn.com/uutiset/" class="dropdown-link">Uutiset</a></li>
						<li><a href="https://fin.afterdawn.com/arvostelut/" class="dropdown-link">Arvostelut</a></li>
						<li><a href="https://fin.afterdawn.com/oppaat/" class="dropdown-link">Oppaat</a></li>
						<li><a href="https://fin.afterdawn.com/paivan-diili" class="dropdown-link">Tarjoukset</a></li>
						<li><a href="https://fin.afterdawn.com/parhaat" class="dropdown-link">Parhaat</a></li>
						<li><a href="https://keskustelu.afterdawn.com/" class="dropdown-link">Keskustelu</a></li>
					</ul>
					<div class="mobile-dropdown_panel not-logged-in">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a>
							<a class="dropdown-link register-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
					<div class="mobile-dropdown_social">
						<a class="social-link fb-link" href="https://www.facebook.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link tw-link" href="https://twitter.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link inst-link" href="https://instagram.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
					</div>
				</div>

				

				
				<a href="https://fin.afterdawn.com/" class="branding" title="AfterDawnin Etusivulle">
					<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" alt="AfterDawn logo">
				</a>
				


				<a class="search" href="#"></a>
				<form class="search-form-m" method="get" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm">
					<input type="search" value="" name="q" placeholder="Hae uutisia..." />
					<input type="submit" value="">
				</form>

				<nav>
					<ul class="menu-main">
						
							<li><a href="https://fin.afterdawn.com/">Etusivu</a></li>
						
							<li><a href="https://fin.afterdawn.com/uutiset/" class="active">Uutiset</a></li>
						
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
						
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						
							<li><a href="https://fin.afterdawn.com/paivan-diili">Tarjoukset</a></li>
						
							<li><a href="https://fin.afterdawn.com/parhaat">Parhaat</a></li>
						
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
						
						
						<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb-m" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
						<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter-m" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
					</ul>
				</nav>
				
				<form class="search-form" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm" method="get">
					<input type="search" value="" name="q" placeholder="Hae uutisia...">
					<input type="submit" value="Hae">
				</form>
			
			

			
			<ul class="menu-some">
				<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
				<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
			</ul>
			
			

		</div>
	</header>

	<div class="no-max-width">
		<ul class="max-width menu-tags">
			
			
				
				<li><a href="https://fin.afterdawn.com/robotti-imurit">Robotti-imurit</a></li>
				<li><a href="https://fin.afterdawn.com/t/kuulokkeiden_arvostelut">Kuulokkeet</a></li>
				<li><a href="https://fin.afterdawn.com/t/robottiruohonleikkuri">Robottiruohonleikkuri</a></li>
				<li><a href="https://fin.afterdawn.com/t/sahkopotkulauta">S&auml;hk&ouml;potkulaudat</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2022/06/30/paras-naytonohjain">Parhaat n&auml;yt&ouml;nohjaimet</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2021/06/22/paras-bluetooth-kaiutin">Parhaat Bluetooth-kaiuttimet</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2021/02/26/halpa-peli-pc">Rakenna halpa peli-PC</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2020/09/15/opas-kovalevyn-vaihto-tietokoneeseen-ssd-tai-hdd">Opas: Kovalevyn vaihto</a></li>
			
			
			
		</ul>
	</div>
	<div class="max-width">



		<div id="nm-160x600" class="ad-160"></div>

		<div class="col1 pin-container">
			<aside class="col1-inner pinned">
				<nav class="menu-sub">

					

					

					

					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/12/14/verkkokauppa-com-verkkis-awards-2022-vuoden-parhaat-tuotteet" title="Samsungin Galaxy S22 Ultra vuoden elektroniikkatuote Verkkokauppa.comilla"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Verkkis-Awards-2022.jpg" alt="Samsungin Galaxy S22 Ultra vuoden elektroniikkatuote Verkkokauppa.comilla" />
								<div class="info">
									<time datetime="2022-12-14T09:46:3Z" class="timeago published">14. December, 2022 11:46</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Samsungin Galaxy S22 Ultra vuoden elektroniikkatuote Verkkokauppa.comilla</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/13/valonnopeuttakin-voidaan-nopeuttaa-microsoft-osti-itselleen-kuituyhtion" title="Valonnopeuttakin voidaan nopeuttaa - Microsoft osti itselleen kuituyhtiön"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Microsoft-logo-2013-horizontal.jpg" alt="Valonnopeuttakin voidaan nopeuttaa - Microsoft osti itselleen kuituyhtiön" />
								<div class="info">
									<time datetime="2022-12-13T15:30:20Z" class="timeago published">13. December, 2022 17:30</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Valonnopeuttakin voidaan nopeuttaa - Microsoft osti itselleen kuituyhtiön</h3>
							</li>
						
					</ul>

					<div id="nm-300x600-300x300" class="ad-300"></div>


					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/12/13/tapahtumatv-eveo-televisiokanava" title="Tapahtumiin erikoistunut televisiokanava aloittaa Suomessa viikonloppuna"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/TapahtumaTV-Eveo.jpg" alt="Tapahtumiin erikoistunut televisiokanava aloittaa Suomessa viikonloppuna" />
								<div class="info">
									<time datetime="2022-12-13T09:04:48Z" class="timeago published">13. December, 2022 11:04</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Tapahtumiin erikoistunut televisiokanava aloittaa Suomessa viikonloppuna</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/12/poista-kuvasi-netista" title="Kommentti: Nyt alkaa olemaan viimeinen hetki poistaa *kaikki* kuvasi netistä - Tekoälyllä niistä luodaan törkysisältöä, mainoksia, videoita, ..."></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/deepfake-mark-zuckerberg.jpg" alt="Kommentti: Nyt alkaa olemaan viimeinen hetki poistaa *kaikki* kuvasi netistä - Tekoälyllä niistä luodaan törkysisältöä, mainoksia, videoita, ..." />
								<div class="info">
									<time datetime="2022-12-12T18:37:2Z" class="timeago published">12. December, 2022 20:37</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Kommentti: Nyt alkaa olemaan viimeinen hetki poistaa *kaikki* kuvasi netistä - Tekoälyllä niistä luodaan törkysisältöä, mainoksia, videoita, ...</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/12/usb-c-pakko-selitys" title="Tätä EU:n USB-C -pakko tarkoittaa: Ei rajoita innovointia, koskee myös läppäreitä, .. - Tarkka päivämäärä päätettiin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/USB-C-cables-2.jpg" alt="Tätä EU:n USB-C -pakko tarkoittaa: Ei rajoita innovointia, koskee myös läppäreitä, .. - Tarkka päivämäärä päätettiin" />
								<div class="info">
									<time datetime="2022-12-12T17:15:0Z" class="timeago published">12. December, 2022 19:15</time>
									<a class="comments" href="/uutiset/2022/12/12/usb-c-pakko-selitys#kommentit">2</a>
								</div>
								<div class="curtain"></div>
								<h3>Tätä EU:n USB-C -pakko tarkoittaa: Ei rajoita innovointia, koskee myös läppäreitä, .. - Tarkka päivämäärä päätettiin</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/12/dyson-zone-kuulokkeet-ilmanpuhdistin-myynti-hinta" title="Dysonin kuulokkeet tuottavat suulle puhdasta ilmaa kalliilla hinnalla"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Dyson-Zone.jpg" alt="Dysonin kuulokkeet tuottavat suulle puhdasta ilmaa kalliilla hinnalla" />
								<div class="info">
									<time datetime="2022-12-12T15:00:28Z" class="timeago published">12. December, 2022 17:00</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Dysonin kuulokkeet tuottavat suulle puhdasta ilmaa kalliilla hinnalla</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/10/gmail-on-nurin-koko-maailmassa-myos-suomessa" title="Gmail on nurin koko maailmassa, myös Suomessa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Gmail-logo-2015.jpg" alt="Gmail on nurin koko maailmassa, myös Suomessa" />
								<div class="info">
									<time datetime="2022-12-10T14:59:46Z" class="timeago published">10. December, 2022 16:59</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Gmail on nurin koko maailmassa, myös Suomessa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/10/tekoaly-voi-tuhota-googlen" title="Gmailin perustaja: Uusi palvelu voi tuhota Googlen parin vuoden sisään - ja se tuhoaisi koko nykyisenkaltaisen Internetin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/chatgpt-parempi-hakukone.jpg" alt="Gmailin perustaja: Uusi palvelu voi tuhota Googlen parin vuoden sisään - ja se tuhoaisi koko nykyisenkaltaisen Internetin" />
								<div class="info">
									<time datetime="2022-12-10T14:08:6Z" class="timeago published">10. December, 2022 16:08</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Gmailin perustaja: Uusi palvelu voi tuhota Googlen parin vuoden sisään - ja se tuhoaisi koko nykyisenkaltaisen Internetin</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/10/dji-mini-3-kevyt-kuvauskopteri-kamera-akku-hinta" title="DJI:n kevyt Mini 3 -kuvauskopteri tarjoaa edeltäjään nähden parempaa akunkestoa ja valokuvaamista"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/DJI-Mini-3.jpg" alt="DJI:n kevyt Mini 3 -kuvauskopteri tarjoaa edeltäjään nähden parempaa akunkestoa ja valokuvaamista" />
								<div class="info">
									<time datetime="2022-12-10T10:34:32Z" class="timeago published">10. December, 2022 12:34</time>
									
								</div>
								<div class="curtain"></div>
								<h3>DJI:n kevyt Mini 3 -kuvauskopteri tarjoaa edeltäjään nähden parempaa akunkestoa ja valokuvaamista</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/09/oda-ruoan-kotiinkuljetus-turku-tampere" title="Netissä toimiva Oda aloittaa ruoan kotiinkuljetukset Turussa ja Tampereella vuoden 2023 alussa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Oda-auto-kuljettaja-lahelta.jpg" alt="Netissä toimiva Oda aloittaa ruoan kotiinkuljetukset Turussa ja Tampereella vuoden 2023 alussa" />
								<div class="info">
									<time datetime="2022-12-09T15:58:2Z" class="timeago published">9. December, 2022 17:58</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Netissä toimiva Oda aloittaa ruoan kotiinkuljetukset Turussa ja Tampereella vuoden 2023 alussa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/09/google-chrome-selain-saasta-muistia-virtaa" title="Chrome kuluttaa nyt vähemmän muistia ja akkua"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Google-Chrome-Memory-Saver.jpg" alt="Chrome kuluttaa nyt vähemmän muistia ja akkua" />
								<div class="info">
									<time datetime="2022-12-09T13:58:49Z" class="timeago published">9. December, 2022 15:58</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Chrome kuluttaa nyt vähemmän muistia ja akkua</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/09/kela-verkkopalvelut-palvelunestohyokkays" title="Kelan verkkopalvelut ongelmissa palvelunestohyökkäysten takia"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Kela-nettisivu-kuvakaappaus-ilmoitus-hairioista.jpg" alt="Kelan verkkopalvelut ongelmissa palvelunestohyökkäysten takia" />
								<div class="info">
									<time datetime="2022-12-09T12:50:37Z" class="timeago published">9. December, 2022 14:50</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Kelan verkkopalvelut ongelmissa palvelunestohyökkäysten takia</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/09/power-plus-myymala-kauppakeskus-itis" title="Kauppakeskus Itiksen Power-myymälä uudistuu - avautuessa Suomen suurin"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Power-Logo-16-9.jpg" alt="Kauppakeskus Itiksen Power-myymälä uudistuu - avautuessa Suomen suurin" />
								<div class="info">
									<time datetime="2022-12-09T10:22:27Z" class="timeago published">9. December, 2022 12:22</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Kauppakeskus Itiksen Power-myymälä uudistuu - avautuessa Suomen suurin</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/08/eu-googlen-pitaa-poistaa-valheelliset-vaittamat-ihmisista-hakutuloksistaan" title="EU: Googlen pitää poistaa valheelliset väittämät ihmisistä hakutuloksistaan"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/european-union-flag-flying.jpg" alt="EU: Googlen pitää poistaa valheelliset väittämät ihmisistä hakutuloksistaan" />
								<div class="info">
									<time datetime="2022-12-08T20:33:32Z" class="timeago published">8. December, 2022 22:33</time>
									<a class="comments" href="/uutiset/2022/12/08/eu-googlen-pitaa-poistaa-valheelliset-vaittamat-ihmisista-hakutuloksistaan#kommentit">3</a>
								</div>
								<div class="curtain"></div>
								<h3>EU: Googlen pitää poistaa valheelliset väittämät ihmisistä hakutuloksistaan</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/08/bbc-tv-kanavat-radio-lopetetaan-2030-luvulla" title="Maailman tunnetuin TV-toimija BBC ennakoi jo TV-lähetysten ja radion kuolemaa kymmenen vuoden sisään"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/bbc-logo-2021.jpg" alt="Maailman tunnetuin TV-toimija BBC ennakoi jo TV-lähetysten ja radion kuolemaa kymmenen vuoden sisään" />
								<div class="info">
									<time datetime="2022-12-08T20:11:49Z" class="timeago published">8. December, 2022 22:11</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Maailman tunnetuin TV-toimija BBC ennakoi jo TV-lähetysten ja radion kuolemaa kymmenen vuoden sisään</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/12/07/stackoverflow-chatgpt-tekoaly-kielto" title="Uusi tekoäly kiellettiin ohjelmoijien tärkeimmällä sivustolla - vastaukset liian hähmäisiä, mutta uskottavia"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/stackoverflow-keyboard.jpg" alt="Uusi tekoäly kiellettiin ohjelmoijien tärkeimmällä sivustolla - vastaukset liian hähmäisiä, mutta uskottavia" />
								<div class="info">
									<time datetime="2022-12-07T18:13:10Z" class="timeago published">7. December, 2022 20:13</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Uusi tekoäly kiellettiin ohjelmoijien tärkeimmällä sivustolla - vastaukset liian hähmäisiä, mutta uskottavia</h3>
							</li>
						
					</ul>

				</nav>

				<div class="footer">
					<a href="/uutiset/">Laajempi uutislistaus</a>
				</div>
			</aside>
		</div>




	

		<div class="col2">
			
			<main class="container">
				
<div id="nm-980x400-fb" class="ad-generic"></div>
<div id="nm-300x300-fb" class="mobile-top-ad"></div>
<div id="nm-1x1-top"></div>


				<article class="article" style="border-top: none;">
					
						<header>
							<h1>Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa</h1>
							

								

								<div class="img-wrap">
									<div class="actions">
										<div class="whatsapp">
											<a href="whatsapp://send" data-text="AfterDawn uutisoi:" data-href="" class="wa_btn wa_btn_s" style="display:none">Jaa</a>
										</div>
										<a class="share-tw" href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">Twiittaa</a>
										<a class="share-fb"href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">Jaa</a>
									</div>
									<picture>
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Laptop-11101001-pexels.webp" type="image/webp" />
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Laptop-11101001-pexels.jpg" type="image/jpeg" />
										<img class="header-img" width="1000"  height="563" src="https://cdn.afterdawn.fi/news/1000x/Laptop-11101001-pexels.jpg" alt="Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa" />
									</picture>
									<!-- <img class="header-img-s" src="https://cdn.afterdawn.fi/v3/news/original/wechat-using-iphone.jpg" alt="lorem ipsum" /> -->
									<!-- <div class="video-container"><iframe width="1050" height="591" src="//www.youtube.com/embed/wPUJKtNfxfo?rel=0" frameborder="0" allowfullscreen></iframe></div> -->
								</div>
							
							<div class="author">
								
									<img loading="lazy" class="gravatar" src="https://www.gravatar.com/avatar/334f78320e16eca9f445f740b5d6a674s=30" alt="Janne Yli-Korhonen" width="30" height="30"/>
									<a class="writer" href="/bio/jyk">Janne Yli-Korhonen</a>
									<ul class="some">
										
											<li><a class="icon-twitter" rel="noopener" href="https://twitter.com/yyyykoooo" title="Janne Yli-Korhonen Twitteriss&auml;" target="_blank"></a></li>
										
										<li><a class="icon-email" href="https://keskustelu.afterdawn.com/conversations/add?to=jyk" title="L&auml;het&auml; yksityisviesti" target="_blank"></a></li>
									</ul>
								
								<div class="info">
									<time datetime="2022-12-14T12:24:48Z" class="timeago published">14. December, 2022 14:24</time>
									
								</div>
							</div>
						</header>

						

						<div class="content">
							
							<div class="sharing-bar">
								<!-- Facebook -->
								<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
								</a>

								<!-- Twitter -->
								<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
								</a>
							</div>
							
							<div class="col-center text">
								<p>Tietoturvayhtiön Check Point Software Technologiesin tutkimustoiminnasta vastaava <b>Check Point Research</b> (CPR) on julkaissut <a href="https://blog.checkpoint.com/2022/12/13/november-2022s-most-wanted-malware-a-month-of-comebacks-for-trojans-as-emotet-and-qbot-make-an-impact/" target="_blank">marraskuun 2022 haittaohjelmakatsauksensa</a>.</p><p>Sekä maailmalla että Suomessa kärjessä on AgentTesla, joka keräilee kaikessa hiljaisuudessa uhrin tietoja, kuten salasanoja.</p><p>AgentTesla oli jo lokakuussa maailman yleisin haittaohjelma, mutta <a href="https://fin.afterdawn.com/uutiset/2022/11/11/suomen-yleisimmat-haittaohjelmat-lokakuu-2022" target="_blank">vielä tuolloin sitä ei nähty Suomen listalla</a>.</p><p>Heinäkuussa 2022 Check Point Research raportoi Emotetin globaalin aktiivisuuden huomattavasta laskusta, epäillen sen olevan vain väliaikaista. Kuten ennustettiin, Emotet nousi uudelleen ja oli marraskuussa maailman toiseksi yleisin haittaohjelma vaikuttaen neljään prosenttiin yritysverkoista.</p><p>Suomessa haitake on nyt kolmanneksi yleisin. Emotetista on varoiteltu runsaasti parin viime vuoden aikana. Esimerkiksi hiljattain <a href="https://fin.afterdawn.com/uutiset/2022/11/10/emotet-haittaohjelma-yleistyy-suomessa-leviaa-sahkopostin-liitteena" target="_blank">Traficomin Kyberturvallisuuskeskus varoitteli Emotetin aktivoitumisesta Suomessa</a>.</p><blockquote>"Vaikka nämä kehittyneet haittaohjelmat voivat välillä olla lepotilassa, viime viikot ovat muistutus siitä, että ne eivät pysy hiljaa pitkään. Varomattomuuteen ei ole varaa ja on tärkeää olla valppaana sähköposteja avatessa, linkkejä klikatessa, verkkosivustoilla käydessä ja henkilökohtaisia tietoja jakaessa", sanoo <b>Maya Horowitz</b>, VP Research Check Point Softwarelta.</blockquote><p>Maailmalla kolmanneksi yleisin haittaohjelma on nyt Qbot.</p><p>Pankkitunnuksia ja näppäinpainalluksia varastava Qbot-troijalainen nousi marraskuun yleisimpien haittaohjelmien listan kolmannelle sijalle vaikuttaen neljään prosenttiin yritysverkoista maailmanlaajuisesti.</p><p>Haittaohjelman taustalla on taloudellista hyötyä tavoittelevia kyberrikollisia, jotka varastavat pankkitunnuksia ja muita taloudellisia tietoja sekä verkkoselaintietoja tartunnan saaneista järjestelmistä. Onnistuttuaan saastuttamaan järjestelmän Qbotin uhkatoimijat asentavat siihen takaoven, josta kiristysohjelmien operaattorit pääsevät sisään. Seurauksena on usein kaksinkertaisia kiristyshyökkäyksiä.</p><p>Lisäksi CPR nostaa esille Raspberry Robinin, joka on kehittynyt mato. Tämä haitake käyttää hyökkäyksissään laillisilta vaikuttavia, mutta tosiasiassa uhrien koneet saastuttavia USB-asemia. Microsoft havaitsi, että Raspberry Robin on kehittynyt laajalti levinneestä madosta tehokkaaksi haittaohjelmien levittäjäksi, joka tarttuu monin tavoin ja muihin haittaohjelmaperheisiin linkittyneenä.<br/></p><div class="video"></div>
			<ins class="adsbygoogle"
				 style="display:block; text-align:center;"
				 data-ad-layout="in-article"
				 data-ad-format="fluid"
				 data-ad-client="ca-pub-5626074131133514"
				 data-ad-slot="2169338932"></ins>
			<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
			<p>
		</p><h2>Suomen yleisimmät haittaohjelmat marraskuussa 2022</h2><ol><li>AgentTesla – Kehittynyt RAT, joka pystyy varastamaan tietoja sekä tarkkailemaan ja tallentamaan näppäintoimintoja, ottamaan kuvakaappauksia ja keräämään kaikessa hiljaisuudessa uhrin käyttämien ohjelmistojen salasanoja. Esiintyvyys 3,23 %.</li><li>XMRig – Monero-kryptovaluutan louhija. Uhkatoimijat väärinkäyttävät usein tätä avoimen lähdekoodin ohjelmistoa ja integroivat sen haittaohjelmiin louhiakseen laittomasti uhrien laitteilla. Esiintyvyys 2,69 %.</li><li>Emotet – Kehittynyt, itsestään leviävä ja modulaarinen pankkitroijalainen, jota käytetään pääasiassa muiden haittaohjelmien levittämiseen. Väistelee virustutkia ja poistoyrityksiä. Pystyy leviämään myös sähköpostiliitteiden ja -linkkien kautta. Esiintyvyys 2,15 %.<li>Formbook – Windows-järjestelmien haittaohjelma, joka kerää uhrien tietoja monin eri tavoin. Esiintyvyys 2,15 %.</li><li>Anubis – Pankki- ja etäkäyttötroijalainen, joka on suunnattu Android-puhelimiin. Kiristysohjelmaominaisuuksillakin varustettu Anubis kykenee tallentamaan myös ääntä ja näppäinpainalluksia. Sitä on havaittu sadoissa Google Storen sovelluksissa. Esiintyvyys 1,61 %.</li><li>NJRat, Remcos, Qbot, Vobfus, Lokibot, Esfury, Crackonosh, BLINDINGCAN, Ramnit. Kaikkien esiintyvyys 1,08 %.</li></ol><p></p>
								
								
									
										<ul class="tags">
											
												<li><a href="/t/check_point" title="Kaikki uutiset aiheesta Check Point">Check Point</a></li>
											
												<li><a href="/t/haittaohjelma" title="Kaikki uutiset aiheesta haittaohjelma">haittaohjelma</a></li>
											
												<li><a href="/t/emotet" title="Kaikki uutiset aiheesta Emotet">Emotet</a></li>
											
												<li><a href="/t/tietoturva" title="Kaikki uutiset aiheesta tietoturva">tietoturva</a></li>
											
										</ul>
									
								

								<!--added sharing bar-->
								<div class="sharing-bottom">
									<!-- Facebook -->
									<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Twitter -->
									<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
									</a>

									<!-- Whatsapp -->
									<a class="wtsp-share" href="https://wa.me/?text=https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/whatsapp.png" alt="Jaa Whatsappissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Sharing icon -->
									<a class="gnrc-share" href="#" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/share-icon.png" alt="" width="35" height="35" loading="lazy" id="btn" />
									</a>
								</div>
								<!--added sharing bar end-->
								
								<script>
									const btn = document.getElementById("btn");

									// function for web share api
									function webShareAPI(header, description, link) {
									  navigator
										.share({
										  title: header,
										  text: description,
										  url: link
										})
										.then(() => console.log("Successful share"))
										.catch((error) => console.log("Error sharing", error));
									}

									if (navigator.share) {
									  // Show button if it supports webShareAPI
									  btn.style.display = "block";
									  btn.addEventListener("click", () =>
										webShareAPI("Nämä ovat marraskuun yleisimmät haittaohjelmat Suomessa", "Sekä maailmalla että Suomessa kärjessä on AgentTesla, joka keräilee kaikessa hiljaisuudessa uhrin tietoja, kuten salasanoja.", "https://fin.afterdawn.com/uutiset/2022/12/14/suomen-yleisimmat-haittaohjelmat-marraskuu-2022")
									  );
									} else {
									  // Hide button if it supports webShareAPI
									  btn.style.display = "none";
									  console.error("Your Browser doesn't support Web Share API");
									}
								</script>

							</div>
							<div id="nm-468x400-300x300" style="margin-bottom:20px;"></div>
							<!-- Tag for Afterdawn.com - Afterdawn_1x1_Adnami_Mid placement -->
							<div id="nm-1x1-mid"></div>
						</div>
					

					
					
					
					
					
					<section class="comment-area" id="kommentit">
						<div class="col-center">
							<div class="title-sub">
								
									<h4>KOMMENTOI</h4>
									<div class="source comment-dark"></div>
								
							</div>
							



							
								
									<div class="logintocomment">
										<p style="font-size: 18px;">
											Haluatko kommentoida t&auml;t&auml; artikkelia?<br/>
											<a href="https://kirjaudu.afterdawn.com/login.cfm?returnURL=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F12%2F14%2Fsuomen%2Dyleisimmat%2Dhaittaohjelmat%2Dmarraskuu%2D2022%23kommentoi">Kirjaudu sis&auml;&auml;n</a> tai <a href="https://kirjaudu.afterdawn.com/create_new_account.cfm?redirect=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F12%2F14%2Fsuomen%2Dyleisimmat%2Dhaittaohjelmat%2Dmarraskuu%2D2022%23kommentoi">Luo uusi k&auml;ytt&auml;j&auml;tunnus</a>.
										</p>
									</div>
								
							
						</div>
					</section>

					

				</article>

				<div class="recommendationElement post">
					<script src="https://widget.high.fi/loadRecommendations.js?v=20180601-01"></script>
				</div>

				

			</main>
		</div>
	
	
		
		
			<footer class="footer">
				<div class="footer-columns">
					<div class="footer-column">
						<div class="footer-logo">
							<a href="https://fin.afterdawn.com/">
								<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" width=251 height=88 style="height:auto;" loading="lazy" alt="AfterDawnin logo">
							</a>
						</div>
						<ul>
							<li><a href="https://fin.afterdawn.com/general/company.cfm">Tietoja meist&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/mainosta">Mainonta</a></li>
							<li><a href="https://fin.afterdawn.com/palaute">Ota yhteytt&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/general/saannot.cfm">K&auml;ytt&ouml;ehdot ja tietoa yksityisyydensuojasta</a></li>
							<li><a href="https://fin.afterdawn.com/general/rekisteriseloste.cfm">Tietosuojaseloste</a></li>
						</ul>
						<div class="footer-logo">
							<a href="https://upcloud.com/signup/?promo=afterdawn" target="_blank" rel="sponsored">
								Yhteydet tarjoaa:<br/>
								<img src="https://cdn.afterdawn.fi/logos/upcloud_logo_horizontal_white_40px.png" width="166" height="45" style="height:auto; margin-left:auto; margin-right:auto;" loading="lazy" alt="UpCloudin logo">
							</a>
						</div>
					</div>
					<div class="footer-column">
						<h4>Osiot:</h4>
						<ul>
							<li><a href="https://fin.afterdawn.com/uutiset/">Uutiset</a></li>
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
							<li><a href="https://fin.afterdawn.com/paivan-diili">P&auml;iv&auml;n diili</a></li>
							<li><a href="https://www.download.fi/">Ohjelmien lataukset</a></li>
							<li><a href="https://www.puhelinvertailu.com/">Mobiilialan uutiset</a></li>
							<li><a href="https://www.puhelinvertailu.com/puhelimet">K&auml;nnyk&ouml;iden tiedot ja vertailu</a></li>
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						</ul>
					</div>
					<div class="footer-column">
						<h4>Seuraa meit&auml;:</h4>
						<ul>
							<li><a href="https://www.facebook.com/afterdawnfi">Facebook</a></li>
							<li><a href="https://twitter.com/afterdawnfi">Twitter</a></li>
							<li><a href="https://www.instagram.com/afterdawnfi/">Instagram</a></li>
							<li><a href="https://www.tiktok.com/@afterdawnfi">TikTok</a></li>
							<li><a href="http://feeds.afterdawn.com/afterdawn_uutiset">RSS-sy&ouml;te</a></li>
							<li><h4 style="padding-top: 0;">Osallistu:</h4></li>
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
							<li><a href="https://x2.fi/">Kysy/Vastaa</a></li>
						</ul>
					</div>
				</div>
				<div class="copyright">
					<div class="copyright-date">&copy; 1999-2022</div>
					<div>
						<a class="copyright-link" href="https://fin.afterdawn.com/">AfterDawn Oy</a>
					</div>
				</div>
			</footer>
		
		

	</div>
	<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
	
		<script type="text/javascript" src="https://cdn.afterdawn.fi/min/f=/scripts/jquery.timeago.js&amp;20201208"></script>
		<script type="text/javascript" src="https://cdn.afterdawn.fi/js/3rd/jquery/locales/jquery.timeago.fi.utf8.js"></script>
	

	<script type="text/javascript">
		$(document).ready(function(){
		  $(".toggle1").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle2, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle2").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle3").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle2").removeClass( "show-onclick" );
		  });
		  $(".search").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		  });

			//burger menu open
			$(".header-burger").click(function () {
				$(".mobile-dropdown").addClass("active");
			});
			//burger menu close
			$(".mobile-dropdown_close").click(function () {
				$(".mobile-dropdown").removeClass("active");
			});

		});

	</script>

	
		
		<script type="text/javascript">
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", $this.outerHeight());
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 190;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '200px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: to - data.parentTop + data.pad.top
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".sharing-bar").pin({containerSelector: ".content"})
		</script>
		
	
	<script type="text/javascript">
		// sidebar fixed
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						var outerHeight = $this.outerHeight();
						var containerHeight = $container.outerHeight();

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", outerHeight);

						// Limit element height on shurt pages
						if (outerHeight > containerHeight) {
							$this.css({height: containerHeight});
							disabled = true; // Disable onScroll
						}
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 120;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '160px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: (to - data.parentTop + data.pad.top) - 120
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".pinned").pin({containerSelector: ".pin-container"})
	</script>
	

	

	<!-- Tapetin kanssa k&auml;ytett&auml;v&auml; js, pit&auml;&auml; eritell&auml; menun paikka -->
	
	<script type="text/javascript">
		jQuery(document).ready(function() {
		  jQuery("time.timeago").timeago();
		});
	</script>
</body>
</html>

