
	
	

	

	
	

	



<!doctype html>
<html lang="fi">
<head>

	<meta charset="UTF-8">

	<link rel="preconnect" href="https://cdn.afterdawn.fi" crossorigin />

	
	

	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback" />
	<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" />

	<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback' rel="stylesheet" media="print" onload="this.media='all'">
	<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback' rel="stylesheet" media="print" onload="this.media='all'">
	<link href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" rel="stylesheet" media="print" onload="this.media='all'">

	<noscript>
		<link href='https://fonts.googleapis.com/css?family=Oswald:400,300,700&display=fallback' rel="stylesheet" />
		<link href='https://fonts.googleapis.com/css?family=Droid+Sans:400,700&display=fallback' rel="stylesheet" />
		<link href="https://fonts.googleapis.com/css?family=Courgette&display=fallback" rel="stylesheet" />
	</noscript>

	

	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=1.0, user-scalable=1" />
	<meta name="HandheldFriendly" content="true">

	<meta name="theme-color" content="#004659">
	
	

		

		<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
		<script>
		  var OneSignal = OneSignal || [];
			OneSignal.push(["init", {
			  appId: "93d08ca6-cfa1-4d6c-a9e9-6494a1c27602",
			}]);
		</script>
		
		

		<!-- Global site tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2099875-2"></script>
		<script>
		  window.dataLayer = window.dataLayer || [];
		  function gtag(){dataLayer.push(arguments);}
		  gtag('js', new Date());

		  gtag('config', 'UA-2099875-2');
		</script>

	

	
		<title>Black Friday 2022 - lista parhaista tarjouksista - AfterDawn</title>
		
			<meta name="author" content="Janne Yli-Korhonen">
		
		<link rel="shortcut icon" href="https://cdn.afterdawn.fi/v4/favicon.ico">
		<meta http-equiv="Content-Language" content="fi" />
		
			
				
		
			
			
				
				<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="canonical" href="https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset"> <link rel="amphtml" href="https://fin.afterdawn.com/amp/uutiset/2022/11/16/parhaat-black-friday-tarjoukset"> 
					<meta name="news_keywords" content="kuulokkeet,robotti-imuri,oheislaitteet,tietokone,älypuhelin,tarjoukset,Black Friday" />
		<meta name="robots" content="max-image-preview:large">
				<script type="application/ld+json">
				{
				  "@context": "https://schema.org",
				  "@type": "BreadcrumbList",
				  "itemListElement": [{
					"@type": "ListItem",
					"position": 1,
					"name": "Tarjoukset",
					"item": "https://fin.afterdawn.com/paivan-diili"
				  },{
					"@type": "ListItem",
					"position": 2,
					"name": "Black Friday 2022 - lista parhaista tarjouksista",
					"item": "https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset"
				  }]
				}
				</script>
			
		
			<script type="application/ld+json">
			{
			"@context": "https://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": "https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset",
			"headline": "Black Friday 2022 - lista parhaista tarjouksista",
			"datePublished": "November, 16 2022 11:38:00 +0000",
			"dateModified": "November, 16 2022 11:38:00 +0000",

			
				"description": "Virallinen Black Friday on tänä vuonna perjantaina 25.11. mutta kampanjat käynnistyvät tänäkin vuonna jo hyvissä ajoin ennen virallista Mustaa Perjantaita ja ne jatkuvat aina Cyber Monday -maanantaille asti.",
			

			
				"author": {
					"@type": "Person",
					"name": "Janne Yli-Korhonen",
					"url": "https://fin.afterdawn.com/bio/jyk"
				},
			

			"publisher": {
			  "@type": "Organization",
			  "name": "AfterDawn",
			  "logo": {
				"@type": "ImageObject",
				"url": "https://cdn.afterdawn.fi/storage/pictures/afterdawn-logo-181x60.jpg",
				"width": 181,
				"height": 60
			  }
			}

			
				,
				"image": [
				  "https://cdn.afterdawn.fi/v3/news/original/Black-Friday-text.jpg",
				  "https://cdn.afterdawn.fi/v3/news/600x400/Black-Friday-text.jpg"
				]
			

				}
			</script>

		
	
		<meta property="og:title" content="Black Friday 2022 - lista parhaista tarjouksista">
		<meta property="og:type" content="article">
		<meta property="og:url" content="https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset">
		<meta property="og:image" content="https://cdn.afterdawn.fi/v3/news/original/Black-Friday-text.jpg">
		<meta property="og:site_name" content="AfterDawn">
		<meta property="fb:app_id" content="121480884529558" />
	
				<meta name="twitter:card" content="summary_large_image">
				<meta name="twitter:site" content="@afterdawnfi">
				
					<meta name="twitter:creator" content="@yyyykoooo">
				
				<meta name="twitter:title" content="Black Friday 2022 - lista parhaista tarjouksista">
				
					<meta name="twitter:description" content="Virallinen Black Friday on tänä vuonna perjantaina 25.11. mutta kampanjat käynnistyvät tänäkin vuonna jo hyvissä ajoin ennen virallista Mustaa Perjantaita ja ne jatkuvat aina Cyber Monday -maanantaille asti.">
				
				<meta name="twitter:image:src" content="https://cdn.afterdawn.fi/v3/news/600x400/Black%2DFriday%2Dtext%2Ejpg">
			
		
		<meta name="description" content="Virallinen Black Friday on tänä vuonna perjantaina 25.11. mutta kampanjat käynnistyvät tänäkin vuonna jo hyvissä ajoin ennen virallista Mustaa Perjantaita ja ne jatkuvat aina Cyber Monday -maanantaille asti." />
		<link rel="apple-touch-icon" href="https://cdn.afterdawn.fi/v3/apple-touch-icon.png">

		

		

		
			<link rel="alternate" type="application/rss+xml" href="https://feeds.feedburner.com/afterdawn_uutiset" title="AfterDawnin uutiset" />
		
		
		

		

	
	
	
	
	

	

	<script>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</script>



	
		
			<link rel="preload" href="https://fin.afterdawn.com/css/styles-min.css?20221030-01" as="style">
			<link rel="stylesheet" href="https://fin.afterdawn.com/css/styles-min.css?20221030-01">
		
	

	

	<script async="async" src="https://macro.adnami.io/macro/hosts/adsm.macro.fin.afterdawn.com.js"></script>

	<link rel="preload" href="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" as="script" crossorigin="anonymous">
	<script src="https://strongbox.nostemedia.fi/p33/s47/afterdawn.com.js" crossorigin="anonymous"></script>

	


</head>
<body>

	<header class="no-max-width header">
		
			<div class="sites">
				
					<ul class="menu-sites">
						<li><a href="https://fin.afterdawn.com/">AfterDawn</a></li>
						<li><a href="https://www.puhelinvertailu.com/">Puhelinvertailu</a></li>
						<li><a href="https://www.hardware.fi/">Hardware.fi</a></li>
						<li><a href="https://www.download.fi/">download.fi</a></li>
						<li><a href="https://x2.fi/">X2.fi</a></li>
						<li><a href="https://high.fi/">HIGH.FI</a></li>
					</ul>
				
				
				
				<div class="login-dropdown not-logged-in">
					<img class="user-logo" src="https://cdn.afterdawn.fi/x2fi/responsive/img/person-icon.png" alt="User img">
					<div class="login-dropdown_panel">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a><br/>
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
				</div>
				
			</div>
			
		
		
		<div class="max-width">

			
			<div class="header-burger">
				<div></div>
				<div></div>
				<div></div>
			</div>
			
			
			

				
			
				<div class="mobile-dropdown">
					<div class="mobile-dropdown_close">
						<div></div>
						<div></div>
					</div>
					<ul class="mobile-dropdown_menu">
						<li><a href="https://fin.afterdawn.com/" class="dropdown-link">Etusivu</a></li>
						<li><a href="https://fin.afterdawn.com/uutiset/" class="dropdown-link">Uutiset</a></li>
						<li><a href="https://fin.afterdawn.com/arvostelut/" class="dropdown-link">Arvostelut</a></li>
						<li><a href="https://fin.afterdawn.com/oppaat/" class="dropdown-link">Oppaat</a></li>
						<li><a href="https://fin.afterdawn.com/paivan-diili" class="dropdown-link">Tarjoukset</a></li>
						<li><a href="https://fin.afterdawn.com/parhaat" class="dropdown-link">Parhaat</a></li>
						<li><a href="https://keskustelu.afterdawn.com/" class="dropdown-link">Keskustelu</a></li>
					</ul>
					<div class="mobile-dropdown_panel not-logged-in">
						
							<a class="dropdown-link login-link" href="https://kirjaudu.afterdawn.com/">Kirjaudu sis&auml;&auml;n</a>
							<a class="dropdown-link register-link" href="https://kirjaudu.afterdawn.com/create_new_account.cfm">Rekister&ouml;idy</a>
						
					</div>
					<div class="mobile-dropdown_social">
						<a class="social-link fb-link" href="https://www.facebook.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link tw-link" href="https://twitter.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
						<a class="social-link inst-link" href="https://instagram.com/afterdawnfi" target="_blank" rel="noreferrer"></a>
					</div>
				</div>

				

				
				<a href="https://fin.afterdawn.com/" class="branding" title="AfterDawnin Etusivulle">
					<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" alt="AfterDawn logo">
				</a>
				


				<a class="search" href="#"></a>
				<form class="search-form-m" method="get" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm">
					<input type="search" value="" name="q" placeholder="Hae uutisia..." />
					<input type="submit" value="">
				</form>

				<nav>
					<ul class="menu-main">
						
							<li><a href="https://fin.afterdawn.com/">Etusivu</a></li>
						
							<li><a href="https://fin.afterdawn.com/uutiset/">Uutiset</a></li>
						
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
						
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						
							<li><a href="https://fin.afterdawn.com/paivan-diili" class="active">Tarjoukset</a></li>
						
							<li><a href="https://fin.afterdawn.com/parhaat">Parhaat</a></li>
						
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
						
						
						<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb-m" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
						<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter-m" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
					</ul>
				</nav>
				
				<form class="search-form" action="https://fin.afterdawn.com/uutiset/hakutulokset.cfm" method="get">
					<input type="search" value="" name="q" placeholder="Hae uutisia...">
					<input type="submit" value="Hae">
				</form>
			
			

			
			<ul class="menu-some">
				<li><a href="https://www.facebook.com/afterdawnfi" class="icon-fb" title="AfterDawn Facebookissa" rel="noreferrer"></a></li>
				<li><a href="https://twitter.com/afterdawnfi" class="icon-twitter" title="AfterDawn Twitteriss&auml;" rel="noreferrer"></a></li>
			</ul>
			
			

		</div>
	</header>

	<div class="no-max-width">
		<ul class="max-width menu-tags">
			
			
				
				<li><a href="https://fin.afterdawn.com/robotti-imurit">Robotti-imurit</a></li>
				<li><a href="https://fin.afterdawn.com/t/kuulokkeiden_arvostelut">Kuulokkeet</a></li>
				<li><a href="https://fin.afterdawn.com/t/robottiruohonleikkuri">Robottiruohonleikkuri</a></li>
				<li><a href="https://fin.afterdawn.com/t/sahkopotkulauta">S&auml;hk&ouml;potkulaudat</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2022/06/30/paras-naytonohjain">Parhaat n&auml;yt&ouml;nohjaimet</a></li>
				<li><a href="https://fin.afterdawn.com/uutiset/2021/06/22/paras-bluetooth-kaiutin">Parhaat Bluetooth-kaiuttimet</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2021/02/26/halpa-peli-pc">Rakenna halpa peli-PC</a></li>
				<li><a href="https://www.hardware.fi/uutiset/artikkeli.cfm/2020/09/15/opas-kovalevyn-vaihto-tietokoneeseen-ssd-tai-hdd">Opas: Kovalevyn vaihto</a></li>
			
			
			
		</ul>
	</div>
	<div class="max-width">



		<div id="nm-160x600" class="ad-160"></div>

		<div class="col1 pin-container">
			<aside class="col1-inner pinned">
				<nav class="menu-sub">

					

					

					

					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/11/15/youtube-shorts-video-60-sekuntia-musiikkia" title="YouTube haastaa yhä paremmin TikTokin - Shorts-videoissa voi nyt käyttää 60 sekunnin edestä musiikkia"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/YouTube-Shorts-phone.jpg" alt="YouTube haastaa yhä paremmin TikTokin - Shorts-videoissa voi nyt käyttää 60 sekunnin edestä musiikkia" />
								<div class="info">
									<time datetime="2022-11-15T21:24:12Z" class="timeago published">15. November, 2022 23:24</time>
									
								</div>
								<div class="curtain"></div>
								<h3>YouTube haastaa yhä paremmin TikTokin - Shorts-videoissa voi nyt käyttää 60 sekunnin edestä musiikkia</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/15/verottaja-ulkomaiset-tilisiirrot" title="Tietosuojavaltuutettu murahti: Suomen Verohallinto pyysi kaikkien suomalaisten kaikki ulkomaiset tilisiirrot vuosien ajan"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Verohallinto-logo-green.jpg" alt="Tietosuojavaltuutettu murahti: Suomen Verohallinto pyysi kaikkien suomalaisten kaikki ulkomaiset tilisiirrot vuosien ajan" />
								<div class="info">
									<time datetime="2022-11-15T19:05:42Z" class="timeago published">15. November, 2022 21:05</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Tietosuojavaltuutettu murahti: Suomen Verohallinto pyysi kaikkien suomalaisten kaikki ulkomaiset tilisiirrot vuosien ajan</h3>
							</li>
						
					</ul>

					<div id="nm-300x600-300x300" class="ad-300"></div>


					<ul>
						
							<li><a class="wrap" href="/uutiset/2022/11/15/lidl-sahkoauto-latauspisteet-maksullinen" title="Lidl muuttaa sähköauton latauspisteet maksullisiksi"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/sahkoauto-kuvake-tie.jpg" alt="Lidl muuttaa sähköauton latauspisteet maksullisiksi" />
								<div class="info">
									<time datetime="2022-11-15T13:02:44Z" class="timeago published">15. November, 2022 15:02</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Lidl muuttaa sähköauton latauspisteet maksullisiksi</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/14/google-my-ad-center" title="Googlen My Ad Centerin avulla voi hallita mainoksissa käytettäviä aiheita"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Google-My-Ad-Center-Customize-Ads.jpg" alt="Googlen My Ad Centerin avulla voi hallita mainoksissa käytettäviä aiheita" />
								<div class="info">
									<time datetime="2022-11-14T16:13:9Z" class="timeago published">14. November, 2022 18:13</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Googlen My Ad Centerin avulla voi hallita mainoksissa käytettäviä aiheita</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/14/remedy-control-2-kehitteilla" title="Remedyn suosittu Control-peli saa jatkoa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/control-game.jpg" alt="Remedyn suosittu Control-peli saa jatkoa" />
								<div class="info">
									<time datetime="2022-11-14T11:40:20Z" class="timeago published">14. November, 2022 13:40</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Remedyn suosittu Control-peli saa jatkoa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/12/singles-day-2022-keskimaarainen-alennusprosentti-keinotekoiset-tarjoukset" title="Singles' Dayn keskimääräinen alennusprosentti varsin pieni - keinotekoisia tarjouksia 9 prosentin verran"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Singles-day-logo-pink.jpg" alt="Singles' Dayn keskimääräinen alennusprosentti varsin pieni - keinotekoisia tarjouksia 9 prosentin verran" />
								<div class="info">
									<time datetime="2022-11-12T13:40:21Z" class="timeago published">12. November, 2022 15:40</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Singles' Dayn keskimääräinen alennusprosentti varsin pieni - keinotekoisia tarjouksia 9 prosentin verran</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/11/qatar-pakottaa-jokaisen-turistin-asentamaan-vakoilusovelluksen" title="Jalkapallon MM-kisoihin? Qatar pakottaa jokaisen turistin asentamaan vakoilusovelluksen kännykkäänsä"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/privacy-graphics.jpg" alt="Jalkapallon MM-kisoihin? Qatar pakottaa jokaisen turistin asentamaan vakoilusovelluksen kännykkäänsä" />
								<div class="info">
									<time datetime="2022-11-11T16:00:41Z" class="timeago published">11. November, 2022 18:00</time>
									<a class="comments" href="/uutiset/2022/11/11/qatar-pakottaa-jokaisen-turistin-asentamaan-vakoilusovelluksen#kommentit">3</a>
								</div>
								<div class="curtain"></div>
								<h3>Jalkapallon MM-kisoihin? Qatar pakottaa jokaisen turistin asentamaan vakoilusovelluksen kännykkäänsä</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/11/netflix-suorat-lahetykset" title="Netflixiin jättimuutos: Aloittaa suorat lähetykset"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/netflix-logo_1920x890.jpg" alt="Netflixiin jättimuutos: Aloittaa suorat lähetykset" />
								<div class="info">
									<time datetime="2022-11-11T15:41:44Z" class="timeago published">11. November, 2022 17:41</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Netflixiin jättimuutos: Aloittaa suorat lähetykset</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/11/poliisi-varoitus-viranomaisten-nimissa-lahetetyt-viestit-maksusuoritus" title="Poliisilta varoitus: Viranomaisten nimissä lähetetyt viestit näyttävät tulevan suomalaisen operaattorin numerosta"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Security-text.jpg" alt="Poliisilta varoitus: Viranomaisten nimissä lähetetyt viestit näyttävät tulevan suomalaisen operaattorin numerosta" />
								<div class="info">
									<time datetime="2022-11-11T14:36:9Z" class="timeago published">11. November, 2022 16:36</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Poliisilta varoitus: Viranomaisten nimissä lähetetyt viestit näyttävät tulevan suomalaisen operaattorin numerosta</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/11/suomen-yleisimmat-haittaohjelmat-lokakuu-2022" title="Nämä ovat Suomen yleisimmät haittaohjelmat lokakuussa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Cyber-crime-hacking-laptop.jpg" alt="Nämä ovat Suomen yleisimmät haittaohjelmat lokakuussa" />
								<div class="info">
									<time datetime="2022-11-11T11:37:24Z" class="timeago published">11. November, 2022 13:37</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Nämä ovat Suomen yleisimmät haittaohjelmat lokakuussa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/11/singles-day-parhaat-tarjoukset" title="Singles' Day 2022 - lista parhaista tarjouksista (Päivitetty klo 09:30)"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Singles-day-logo-pink.jpg" alt="Singles' Day 2022 - lista parhaista tarjouksista (Päivitetty klo 09:30)" />
								<div class="info">
									<time datetime="2022-11-11T07:31:0Z" class="timeago published">11. November, 2022 9:31</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Singles' Day 2022 - lista parhaista tarjouksista (Päivitetty klo 09:30)</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/10/lamminvesivaraaja-ja-lattialammitys-paalle-porssisahkon-mukaan" title="Suomalaismies julkaisi ohjeet ja koodin: Lämminvesivaraaja ja lattialämmitys päälle pörssisähkön mukaan itsestään"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/electricity-bill-meme.jpg" alt="Suomalaismies julkaisi ohjeet ja koodin: Lämminvesivaraaja ja lattialämmitys päälle pörssisähkön mukaan itsestään" />
								<div class="info">
									<time datetime="2022-11-10T17:40:44Z" class="timeago published">10. November, 2022 19:40</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Suomalaismies julkaisi ohjeet ja koodin: Lämminvesivaraaja ja lattialämmitys päälle pörssisähkön mukaan itsestään</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/10/emotet-haittaohjelma-yleistyy-suomessa-leviaa-sahkopostin-liitteena" title="Emotet-haittaohjelma yleistyy jälleen Suomessa - leviää sähköpostin liitteenä"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Virus-detected-laptop.jpg" alt="Emotet-haittaohjelma yleistyy jälleen Suomessa - leviää sähköpostin liitteenä" />
								<div class="info">
									<time datetime="2022-11-10T14:58:55Z" class="timeago published">10. November, 2022 16:58</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Emotet-haittaohjelma yleistyy jälleen Suomessa - leviää sähköpostin liitteenä</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/10/razer-wolverine-v2-pro-peliohjain-ps5-pc-hinta" title="Razerin Wolverine V2 Pro on kallis PS5-ohjain"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Razer-Wolverine-V2-Pro-1.jpg" alt="Razerin Wolverine V2 Pro on kallis PS5-ohjain" />
								<div class="info">
									<time datetime="2022-11-10T10:46:14Z" class="timeago published">10. November, 2022 12:46</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Razerin Wolverine V2 Pro on kallis PS5-ohjain</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/09/oda-ruoan-kotiinkuljetus-lohja-riihimaki-nummela" title="Oda aloittaa ruoan kotiinkuljetukset Lohjalla, Riihimäellä ja Nummelassa"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Oda-kuljetusauto-1.jpg" alt="Oda aloittaa ruoan kotiinkuljetukset Lohjalla, Riihimäellä ja Nummelassa" />
								<div class="info">
									<time datetime="2022-11-09T15:34:33Z" class="timeago published">9. November, 2022 17:34</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Oda aloittaa ruoan kotiinkuljetukset Lohjalla, Riihimäellä ja Nummelassa</h3>
							</li>
						
							<li><a class="wrap" href="/uutiset/2022/11/09/neste-asema-sahkolatauspalvelu" title="Nesteen asemille luvassa sähköisten ajoneuvojen suurteholatauspalvelu"></a>
								<img loading="lazy" src="https://cdn.afterdawn.fi/v3/news/600x400/Kempower-production.jpg" alt="Nesteen asemille luvassa sähköisten ajoneuvojen suurteholatauspalvelu" />
								<div class="info">
									<time datetime="2022-11-09T09:58:46Z" class="timeago published">9. November, 2022 11:58</time>
									
								</div>
								<div class="curtain"></div>
								<h3>Nesteen asemille luvassa sähköisten ajoneuvojen suurteholatauspalvelu</h3>
							</li>
						
					</ul>

				</nav>

				<div class="footer">
					<a href="/uutiset/">Laajempi uutislistaus</a>
				</div>
			</aside>
		</div>




	

		<div class="col2">
			<main class="container">
				
<div id="nm-980x400-fb" class="ad-generic"></div>
<div id="nm-300x300-fb" class="mobile-top-ad"></div>
<div id="nm-1x1-top"></div>


				<article class="article" style="border-top: none;">
					
						<header>
							<h1>Black Friday 2022 - lista parhaista tarjouksista</h1>
							

								

								<div class="img-wrap">
									<div class="actions">
										<div class="whatsapp">
											<a href="whatsapp://send" data-text="AfterDawn uutisoi:" data-href="" class="wa_btn wa_btn_s" style="display:none">Jaa</a>
										</div>
										<a class="share-tw" href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">Twiittaa</a>
										<a class="share-fb"href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">Jaa</a>
									</div>
									<picture>
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Black-Friday-text.webp" type="image/webp" />
										<source srcset="https://cdn.afterdawn.fi/news/1000x/Black-Friday-text.jpg" type="image/jpeg" />
										<img class="header-img" width="1000"  height="470" src="https://cdn.afterdawn.fi/news/1000x/Black-Friday-text.jpg" alt="Black Friday 2022 - lista parhaista tarjouksista" />
									</picture>
									<!-- <img class="header-img-s" src="https://cdn.afterdawn.fi/v3/news/original/wechat-using-iphone.jpg" alt="lorem ipsum" /> -->
									<!-- <div class="video-container"><iframe width="1050" height="591" src="//www.youtube.com/embed/wPUJKtNfxfo?rel=0" frameborder="0" allowfullscreen></iframe></div> -->
								</div>
							
							<div class="author">
								
									<img loading="lazy" class="gravatar" src="https://www.gravatar.com/avatar/334f78320e16eca9f445f740b5d6a674s=30" alt="Janne Yli-Korhonen" width="30" height="30"/>
									<a class="writer" href="/bio/jyk">Janne Yli-Korhonen</a>
									<ul class="some">
										
											<li><a class="icon-twitter" rel="noopener" href="https://twitter.com/yyyykoooo" title="Janne Yli-Korhonen Twitteriss&auml;" target="_blank"></a></li>
										
										<li><a class="icon-email" href="https://keskustelu.afterdawn.com/conversations/add?to=jyk" title="L&auml;het&auml; yksityisviesti" target="_blank"></a></li>
									</ul>
								
								<div class="info">
									<time datetime="2022-11-16T11:38:0Z" class="timeago published">16. November, 2022 13:38</time>
									
								</div>
							</div>
						</header>

						

						<div class="content">
							
							<div class="sharing-bar">
								<!-- Facebook -->
								<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
								</a>

								<!-- Twitter -->
								<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">
									<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
								</a>
							</div>
							
							<div class="col-center text">
								<p>Virallinen <b>Black Friday</b> on tänä vuonna perjantaina 25.11. mutta kampanjat käynnistyvät tänäkin vuonna jo hyvissä ajoin ennen virallista Mustaa Perjantaita ja ne jatkuvat aina Cyber Monday -maanantaille asti.</p><p>Tarjouksia on luonnollisesti saatavilla satoja, mutta kaikki niistä eivät ole hyviä. Tähän juttuun keräämme mielestämme parhaimmat tarjoukset ja päivitämme listaa jatkuvasti.</p><p>Listaan on merkittynä tuotteen nimi (linkit vievät yhteistyökumppanimme Hintaoppaan sivulle), tuotteen hinta nyt sekä sulkuihin hinta, jolla tuotetta on viime aikoina saanut ja jälleenmyyjä.</p><p><i>Osa tarjouksista on jo voimassa, mutta osa tulee saataville myöhemmin. Esimerkiksi Gigantilla Black Friday alkaa torstaina klo 10.00.</i></p><h2>Puhelimet</h2><ul><li><a href="https://hintaopas.fi/product.php?p=5838252&ref=61553" target="_blank" rel="sponsored">Samsung Galaxy Z Flip 3 (8/128 GB)</a> - hinta nyt 599 euroa (629 euroa) - Gigantti</li><li><a href="https://hintaopas.fi/product.php?p=6016588&ref=61553" target="_blank" rel="sponsored">Samsung Galaxy A53 5G</a> - hinta nyt 299 euroa (379 euroa) - Veikon Kone, Gigantti</li><li><a href="https://hintaopas.fi/product.php?p=5945709&ref=61553" target="_blank" rel="sponsored">Xiaomi 12</a> - hinta nyt 499 euroa (516 euroa) - Veikon Kone</li><li><a href="https://hintaopas.fi/product.php?p=6469489&ref=61553" target="_blank" rel="sponsored">Samsung Galaxy A13 5G</a> - hinta nyt 149 euroa (179 euroa) - Veikon Kone, Gigantti, DNA</li></ul><p><br/>Lue <a href="https://www.puhelinvertailu.com/arvostelut" target="_blank">Puhelinvertailun arvostelut täältä</a> ja katso <a href="https://www.puhelinvertailu.com/puhelimet" target="_blank">puhelinten speksit täältä</a>.</p><h2>Kellot ja rannekkeet</h2><ul><li><a href="https://hintaopas.fi/product.php?p=5793556&ref=61553" target="_blank" rel="sponsored">Suunto 9 Peak</a> - hinta nyt 349 euroa (369 euro) - XXL</li></ul><h2>Kuulokkeet / kaiuttimet</h2><ul><li><a href="https://hintaopas.fi/product.php?p=7162288&ref=61553" target="_blank" rel="sponsored">Bose QuietComfort SE</a> - hinta nyt 249 euroa (349 euro) - Gigantti</li><li><a href="https://hintaopas.fi/product.php?p=5895125&ref=61553" target="_blank" rel="sponsored">JBL Flip 6 Bluetooth kaiutin</a> - hinta nyt 79 euroa (99 euroa) - Veikon Kone</li></ul><h2>Tietokoneet / tabletit</h2><ul><li><a href="https://hintaopas.fi/product.php?p=5865855&ref=61553" target="_blank" rel="sponsored">Xiaomi Pad 5</a> - hinta nyt 299 euroa (379 euroa) - DNA, Elisa</li></ul><h2>Televisiot</h2><ul><li><a href="https://hintaopas.fi/product.php?p=6150421&ref=61553" target="_blank" rel="sponsored">Samsung 43" Q68B 4K QLED</a> - hinta nyt 499 euroa (599 euro) - Gigantti</li><li><a href="https://hintaopas.fi/product.php?p=6150446&ref=61553" target="_blank" rel="sponsored">Samsung 55" Q68B 4K QLED</a> - hinta nyt 599 euroa (799 euroa) - Gigantti</li></ul><h2>Robotti-imurit</h2><ul><li><a href="https://hintaopas.fi/product.php?p=5048470&ref=61553" target="_blank" rel="sponsored">iRobot Roomba i7</a> - hinta nyt 299 euroa (379 euroa) - Gigantti</li><li><a href="https://hintaopas.fi/product.php?p=5954623&ref=61553" target="_blank" rel="sponsored">Roborock S7 MaxV</a> - hinta nyt 619 euroa (679 euroa) - Gigantti</li></ul><p><br/>Katso tämän hetken <a href="https://fin.afterdawn.com/uutiset/2022/09/23/paras-robotti-imuri" target="_blank">parhaat robotti-imurit täältä</a> sekä <a href="https://fin.afterdawn.com/robotti-imurit" target="_blank">robotti-imureiden tekniset tiedot täältä</a>.<br/></p><div class="video"></div>
			<ins class="adsbygoogle"
				 style="display:block; text-align:center;"
				 data-ad-layout="in-article"
				 data-ad-format="fluid"
				 data-ad-client="ca-pub-5626074131133514"
				 data-ad-slot="2169338932"></ins>
			<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
			<p>
		<br/><i>Tämä artikkeli sisältää yhteistyökumppaneiden linkkejä. Tuotteen hinta ei muutu, mutta saamme mahdollisesti siitä pienen komission.</i></p>
								
								
									
										<ul class="tags">
											
												<li><a href="/t/kuulokkeet" title="Kaikki uutiset aiheesta kuulokkeet">kuulokkeet</a></li>
											
												<li><a href="/t/robotti-imuri" title="Kaikki uutiset aiheesta robotti-imuri">robotti-imuri</a></li>
											
												<li><a href="/t/oheislaitteet" title="Kaikki uutiset aiheesta oheislaitteet">oheislaitteet</a></li>
											
												<li><a href="/t/tietokone" title="Kaikki uutiset aiheesta tietokone">tietokone</a></li>
											
												<li><a href="/t/alypuhelin" title="Kaikki uutiset aiheesta älypuhelin">älypuhelin</a></li>
											
												<li><a href="/t/tarjoukset" title="Kaikki uutiset aiheesta tarjoukset">tarjoukset</a></li>
											
												<li><a href="/t/black_friday" title="Kaikki uutiset aiheesta Black Friday">Black Friday</a></li>
											
										</ul>
									
								

								<!--added sharing bar-->
								<div class="sharing-bottom">
									<!-- Facebook -->
									<a href="https://www.facebook.com/sharer.php?u=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/facebook.png" alt="Jaa Facebookissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Twitter -->
									<a href="https://twitter.com/share?url=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/twitter.png" alt="Jaa Twitteriss&auml;" width="35" height="35" loading="lazy">
									</a>

									<!-- Whatsapp -->
									<a class="wtsp-share" href="https://wa.me/?text=https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/whatsapp.png" alt="Jaa Whatsappissa" width="35" height="35" loading="lazy">
									</a>

									<!-- Sharing icon -->
									<a class="gnrc-share" href="#" target="_blank" rel="noreferrer">
										<img src="https://cdn.afterdawn.fi/x2fi/responsive/img/share-icon.png" alt="" width="35" height="35" loading="lazy" id="btn" />
									</a>
								</div>
								<!--added sharing bar end-->
								
								<script>
									const btn = document.getElementById("btn");

									// function for web share api
									function webShareAPI(header, description, link) {
									  navigator
										.share({
										  title: header,
										  text: description,
										  url: link
										})
										.then(() => console.log("Successful share"))
										.catch((error) => console.log("Error sharing", error));
									}

									if (navigator.share) {
									  // Show button if it supports webShareAPI
									  btn.style.display = "block";
									  btn.addEventListener("click", () =>
										webShareAPI("Black Friday 2022 - lista parhaista tarjouksista", "Virallinen Black Friday on tänä vuonna perjantaina 25.11. mutta kampanjat käynnistyvät tänäkin vuonna jo hyvissä ajoin ennen virallista Mustaa Perjantaita ja ne jatkuvat aina Cyber Monday -maanantaille asti.", "https://fin.afterdawn.com/uutiset/2022/11/16/parhaat-black-friday-tarjoukset")
									  );
									} else {
									  // Hide button if it supports webShareAPI
									  btn.style.display = "none";
									  console.error("Your Browser doesn't support Web Share API");
									}
								</script>

							</div>
							<div id="nm-468x400-300x300" style="margin-bottom:20px;"></div>
							<!-- Tag for Afterdawn.com - Afterdawn_1x1_Adnami_Mid placement -->
							<div id="nm-1x1-mid"></div>
						</div>
					

					
					
					
					
					
					<section class="comment-area" id="kommentit">
						<div class="col-center">
							<div class="title-sub">
								
									<h4>KOMMENTOI</h4>
									<div class="source comment-dark"></div>
								
							</div>
							



							
								
									<div class="logintocomment">
										<p style="font-size: 18px;">
											Haluatko kommentoida t&auml;t&auml; artikkelia?<br/>
											<a href="https://kirjaudu.afterdawn.com/login.cfm?returnURL=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F11%2F16%2Fparhaat%2Dblack%2Dfriday%2Dtarjoukset%23kommentoi">Kirjaudu sis&auml;&auml;n</a> tai <a href="https://kirjaudu.afterdawn.com/create_new_account.cfm?redirect=https%3A%2F%2Ffin%2Eafterdawn%2Ecom%2Fuutiset%2F2022%2F11%2F16%2Fparhaat%2Dblack%2Dfriday%2Dtarjoukset%23kommentoi">Luo uusi k&auml;ytt&auml;j&auml;tunnus</a>.
										</p>
									</div>
								
							
						</div>
					</section>

					

				</article>

				<div class="recommendationElement post">
					<script src="https://widget.high.fi/loadRecommendations.js?v=20180601-01"></script>
				</div>

				

			</main>
		</div>
	
	
		
		
			<footer class="footer">
				<div class="footer-columns">
					<div class="footer-column">
						<div class="footer-logo">
							<a href="https://fin.afterdawn.com/">
								<img src="https://cdn.afterdawn.fi/v4/topBar/logoDAWNv4.gif" width=251 height=88 style="height:auto;" loading="lazy" alt="AfterDawnin logo">
							</a>
						</div>
						<ul>
							<li><a href="https://fin.afterdawn.com/general/company.cfm">Tietoja meist&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/mainosta">Mainonta</a></li>
							<li><a href="https://fin.afterdawn.com/palaute">Ota yhteytt&auml;</a></li>
							<li><a href="https://fin.afterdawn.com/general/saannot.cfm">K&auml;ytt&ouml;ehdot ja tietoa yksityisyydensuojasta</a></li>
							<li><a href="https://fin.afterdawn.com/general/rekisteriseloste.cfm">Tietosuojaseloste</a></li>
						</ul>
						<div class="footer-logo">
							<a href="https://upcloud.com/signup/?promo=afterdawn" target="_blank" rel="sponsored">
								Yhteydet tarjoaa:<br/>
								<img src="https://cdn.afterdawn.fi/logos/upcloud_logo_horizontal_white_40px.png" width="166" height="45" style="height:auto; margin-left:auto; margin-right:auto;" loading="lazy" alt="UpCloudin logo">
							</a>
						</div>
					</div>
					<div class="footer-column">
						<h4>Osiot:</h4>
						<ul>
							<li><a href="https://fin.afterdawn.com/uutiset/">Uutiset</a></li>
							<li><a href="https://fin.afterdawn.com/arvostelut/">Arvostelut</a></li>
							<li><a href="https://fin.afterdawn.com/paivan-diili">P&auml;iv&auml;n diili</a></li>
							<li><a href="https://www.download.fi/">Ohjelmien lataukset</a></li>
							<li><a href="https://www.puhelinvertailu.com/">Mobiilialan uutiset</a></li>
							<li><a href="https://www.puhelinvertailu.com/puhelimet">K&auml;nnyk&ouml;iden tiedot ja vertailu</a></li>
							<li><a href="https://fin.afterdawn.com/oppaat/">Oppaat</a></li>
						</ul>
					</div>
					<div class="footer-column">
						<h4>Seuraa meit&auml;:</h4>
						<ul>
							<li><a href="https://www.facebook.com/afterdawnfi">Facebook</a></li>
							<li><a href="https://twitter.com/afterdawnfi">Twitter</a></li>
							<li><a href="https://www.instagram.com/afterdawnfi/">Instagram</a></li>
							<li><a href="https://www.tiktok.com/@afterdawnfi">TikTok</a></li>
							<li><a href="http://feeds.afterdawn.com/afterdawn_uutiset">RSS-sy&ouml;te</a></li>
							<li><h4 style="padding-top: 0;">Osallistu:</h4></li>
							<li><a href="https://keskustelu.afterdawn.com/">Keskustelu</a></li>
							<li><a href="https://x2.fi/">Kysy/Vastaa</a></li>
						</ul>
					</div>
				</div>
				<div class="copyright">
					<div class="copyright-date">&copy; 1999-2022</div>
					<div>
						<a class="copyright-link" href="https://fin.afterdawn.com/">AfterDawn Oy</a>
					</div>
				</div>
			</footer>
		
		

	</div>
	<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
	
		<script type="text/javascript" src="https://cdn.afterdawn.fi/min/f=/scripts/jquery.timeago.js&amp;20201208"></script>
		<script type="text/javascript" src="https://cdn.afterdawn.fi/js/3rd/jquery/locales/jquery.timeago.fi.utf8.js"></script>
	

	<script type="text/javascript">
		$(document).ready(function(){
		  $(".toggle1").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle2, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle2").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle3").removeClass( "show-onclick" );
		  });
		  $(".toggle3").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		    $(".toggle1, .toggle2").removeClass( "show-onclick" );
		  });
		  $(".search").click(function(){
		    $( this ).toggleClass( "show-onclick" );
		  });

			//burger menu open
			$(".header-burger").click(function () {
				$(".mobile-dropdown").addClass("active");
			});
			//burger menu close
			$(".mobile-dropdown_close").click(function () {
				$(".mobile-dropdown").removeClass("active");
			});

		});

	</script>

	
		
		<script type="text/javascript">
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", $this.outerHeight());
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 190;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '200px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: to - data.parentTop + data.pad.top
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".sharing-bar").pin({containerSelector: ".content"})
		</script>
		
	
	<script type="text/javascript">
		// sidebar fixed
		(function ($) {
			"use strict";
			$.fn.pin = function (options) {
				var scrollY = 0, elements = [], disabled = false, $window = $(window);

				options = options || {};

				var recalculateLimits = function () {
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = elements[i];

						if (options.minWidth && $window.width() <= options.minWidth) {
							if ($this.parent().is(".pin-wrapper")) { $this.unwrap(); }
							$this.css({width: "", left: "", top: "", position: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
							disabled = true;
							continue;
						} else {
							disabled = false;
						}

						var $container = options.containerSelector ? $this.closest(options.containerSelector) : $(document.body);
						var offset = $this.offset();
						var containerOffset = $container.offset();
						var parentOffset = $this.offsetParent().offset();

						if (!$this.parent().is(".pin-wrapper")) {
							$this.wrap("<div class='pin-wrapper'>");
						}

						var pad = $.extend({
							top: 0,
							bottom: 0
						}, options.padding || {});

						$this.data("pin", {
							pad: pad,
							from: (options.containerSelector ? containerOffset.top : offset.top) - pad.top,
							to: containerOffset.top + $container.height() - $this.outerHeight() - pad.bottom,
							end: containerOffset.top + $container.height(),
							parentTop: parentOffset.top
						});

						var outerHeight = $this.outerHeight();
						var containerHeight = $container.outerHeight();

						$this.css({width: $this.outerWidth()});
						$this.parent().css("height", outerHeight);

						// Limit element height on shurt pages
						if (outerHeight > containerHeight) {
							$this.css({height: containerHeight});
							disabled = true; // Disable onScroll
						}
					}
				};

				var onScroll = function () {
					if (disabled) { return; }

					scrollY = $window.scrollTop() + 120;

					var elmts = [];
					for (var i=0, len=elements.length; i<len; i++) {
						var $this = $(elements[i]),
								data  = $this.data("pin");

						if (!data) { // Removed element
							continue;
						}

						elmts.push($this);

						var from = data.from - data.pad.bottom,
								to = data.to - data.pad.top;

						if (from + $this.outerHeight() > data.end) {
							$this.css('position', '');
							continue;
						}

						if (from < scrollY && to > scrollY) {
							!($this.css("position") == "fixed") && $this.css({
								left: $this.offset().left,
								top: '160px'
							}).css("position", "fixed");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else if (scrollY >= to) {
							$this.css({
								left: "",
								top: (to - data.parentTop + data.pad.top) - 120
							}).css("position", "absolute");
							if (options.activeClass) { $this.addClass(options.activeClass); }
						} else {
							$this.css({position: "", top: "", left: ""});
							if (options.activeClass) { $this.removeClass(options.activeClass); }
						}
					}
					elements = elmts;
				};

				var update = function () { recalculateLimits(); onScroll(); };

				this.each(function () {
					var $this = $(this),
							data  = $(this).data('pin') || {};

					if (data && data.update) { return; }
					elements.push($this);
					$("img", this).one("load", recalculateLimits);
					data.update = update;
					$(this).data('pin', data);
				});

				$window.scroll(onScroll);
				$window.resize(function () { recalculateLimits(); });
				recalculateLimits();

				$window.on('load', update);

				return this;
			};
		})(jQuery);

		$(".pinned").pin({containerSelector: ".pin-container"})
	</script>
	

	

	<!-- Tapetin kanssa k&auml;ytett&auml;v&auml; js, pit&auml;&auml; eritell&auml; menun paikka -->
	
	<script type="text/javascript">
		jQuery(document).ready(function() {
		  jQuery("time.timeago").timeago();
		});
	</script>
</body>
</html>

