1   0

Excel kaksi funktiota samaan soluun

Minulla on kaava =PYÖRISTÄ.KERR.YLÖS(P33;0,5)
Mutta haluaisin siihen lisätä myös että jos tämän kaavan tulos on alle 1 niin tulos on 1.

En millään keksi miten se tehdään jotta saisin sen samaan lauseeseen. En haluaisi tehdä sitä toiseen sarakkeeseen koska joutuisin muuttamaan niin monta muuta kaavaa.

Kysyjä: Anonyymi käyttäjä, 24.3.2018 23:00

Vastaukset

  2   1
wiza (167)

=JOS(A1>=1; PYÖRISTÄ.KERR.YLÖS(A1;0,5); 1)

Eli tuo käytännössä:
Jos solun alkio on suurempi tai yhtäsuuri kuin 1 niin pyöristää,
Muuten palauttaa 1

25.3.2018 11:15
  2   1
Vahvistamaton käyttäjä

JOS funtiota hiukan tarkemmin

=JOS(ehto;JosEhtoTOSI;josEhtoEPÄTOSI)
Huomattava on, että kumpikin (ehtoTOSI tai EhtoEPÄTOSI) voi olla oma funktionsa.
Näitä voi myös ketjuttaa pitemmälle. EhtoTOSI tai EhtoTOSI voi myös olla JOS funktio jolla oma ehto ja tosi/epätosi lopputulos.(tai mikä tahansa muu funktio)
Tosin mitä useamman sisäkkäisen funktion laittaa samaan lauseeseen, sitä mielenkiintoisempaa on etsiä ja korjata kun haluaa muutoksia taulukkoon

25.3.2018 16:04
  0   0
Vahvistamaton käyttäjä

Excel kaksi funktiota samaan soluun (4 vastausta) - X2.fi
ffensqrne http://www.g9c9e6x30k86v23fb9e93d8cct42m7jes.org/
uffensqrne
<a href="http://www.g9c9e6x30k86v23fb9e93d8cct42m7jes.org/">affensqrne</a>

16.9.2020 02:09

Ehdota parempaa vastausta

Voit osallistua myös täysin nimettömästi ilman käyttäjätunnusta.
Mikäli sinulla ei ole vielä AfterDawn-käyttäjätunnusta, syötä allaolevaan kaavakkeeseen toivomasi käyttäjätunnus sekä sähköpostiosoitteesi. Lähetämme sinulle jälkikäteen aktivointilinkin antamaasi sähköpostiosoitteeseen.

Mikäli sinulla on jo ennestään AfterDawn-käyttäjätunnus, kirjaudu sisään seuraavan välilehden kautta.

Kirjaudu sisään käyttäen AfterDawn -käyttäjätunnustasi tai sähköpostiosoitettasi.


Kysy.

150