*
 
AfterDawn: IT-alan uutiset

Mozilla suunnittelee versionumeroiden tiputtamista Firefoxista

Kirjoittaja Teemu Laitila @ 18.8.2011 10:46 Kommentteja (8)

Mozilla suunnittelee versionumeroiden tiputtamista Firefoxista Firefox-selaimen kehittäjät ovat julkaisseet suunnitelmansa, jonka mukaan selaimen About:Firefox-inforuudusta poistetaan kokonaan selaimen versionumero. Kehittäjät perustelevat päätöstään siirtymisellä lähemmäs web-tekniikan käytäntöjä, jossa versionumerolla ei ole merkitystä, kunhan käytössä on uusin versio.
Suunnitelmaa on kuitenkin arvosteltu vahvasti käyttäjien toimesta. Mozillan sivuilla käytyjen keskustelujen perusteella vuosikymmeniä sovelluskehityksessä käytettyjen versionumeroperiaatteiden hylkääminen ei saa juuri kannatusta. Lähes minkä tahansa sovelluksen tarkan version pystyy tarkistamaan sovelluksen About-ruudusta.


Firefoxin beta-version Auroran About-laatikko kertoo versionumeroksi 7.0a2


Mozillan kehittäjiä on syytetty käyttäjien mielipiteiden täydellisestä huomiotta jättämisestä. Kehittäjät perustelevat muuttumatonta kantaansa sillä, että vaikka käyttäjiä kuunnellaan, kehitystyön jokaisesta asiasta ei ole syytä järjestää yleistä äänestystä.

Versionumeroiden merkityksen vähentäminen on ollut Firefoxinkin kohdalla käynnissä jo pidempään. Esimerkiksi selainta ladattaessa lataussivu ei enää kerro suoranaisesti ladattavan sovelluksen tarkkaa versiota.

Firefoxin kilpailijoista erityisesti Googlen Chrome ei ole ikinä sisältänyt nimessään versionumeroa, vaikka säännöllisesti tehtyjen päivitysten myötä About-laatikossa mainittu versionumero kasvaakin.

Tägit: Firefox
Edellinen Seuraava  

8 kommenttia

118.8.2011 11:33
jythvcjhfj
Vahvistamaton

Mozillalla alkaa mopo karkaamaan käsistä keuliessaan. Tämä on todella sääli. Hyvä selain pilataan tällaisilla toimilla. Jo nyt tämä nopea päivitystahti johti siihen, että lisäosat tulevat perässä eikä uusimpiin ole saatavilla kaikkia heti, ei edes niitä muutamaa olennaisinta joita itse tulee käytettyä.. Adblock plus, wot, firegestures. No noista ennenkaikkea firegestures ei pysy mukana..

Google Chromeen saa kaikki vastaavat lisäosat ja omassa käytössäni on vakaampi ja koko konekin on. Pahimmillaan foxilla kone (läppäri) jumittaa etenkin flash sisältöä sisältäviä sivuja kun on auki. Jää jumiin niin pahoin, että caps lock valo jää vilkkumaan eikä kone reagoi mihinkään muuhun kuin virtanapin pitkään painallukseen.. Chromella moista ongelmaa ei ole ilmennyt, vaikka muutoin en siitä niin kauheasti pidäkään, olkoonkin että onhan se nopeampikin...

Kaikki tuo on todella sääli, koko kehityskulku siitä lähtien kun itse foxia olen käyttänyt versiosta phoenix 0.6 vai oliko 0.8. Selain on paisunut paisumistaan eikä kehitys kaikilta osin ole todellakaan ollut hyvää.

218.8.2011 11:59
X-fox
Vahvistamaton

Samaa mieltä kuin edellinen kirjoittaja, tosin ed. kirjoittajan ongelmat saattavat johtua Adoben koodista, en ole huomannut Gnashin kanssa samanlaista ongelmaa. Mikä vika on versionumeroissa, että niistä pitää luopua?

Phoenix 0.5 oli aikoinaan edistyksellinen selain, ainoa, jossa oli mm. vakavasti otettava PNG-tuki ja välilehdet. Olen minä edelleen ff-variaation käyttäjä, mutta alamäkeä on selvästi havaittavissa.
Ensin pluginit rikkoutuivat jokaisessa versiopäivityksessä, sitten ulkoasu muuttuu aivan toiseksi joka releasessa, sitten rikotaan yleistä FLOSS-ohjelmien versionumerointiperiaatetta vastaan väittämällä minor-päivitystä niin merkittäväksi että pääversionumerota pitää nostaa.. Ja nyt tämä. Ei hyvää päivää.

Hävettää ihan nämä mozilla-foundationin ailahtelut.

318.8.2011 12:46

Itselläni Firefox päivittää automaattisesti beta versioihin. Tällöin jo kuutos versioiden yhteydessä forefox jätti pois versionumeroinnin. Raivostuttavaa kun forefox usein päivitti itseään mutta mistään ei näe mihin versioon selain päivittyi...

Jos versionumerot jätetään pois niin mitäs sitten tehdään jos koneella olevasta selaimesta lakkaa toimimasta automaattinen päivitys. Siinäpähän sitten arvailet onko koneessa uusin versio selaimesta. "Helppoa" on myös tarkastaa lisäosien yhteensopivuus oman koneella olevan selaimen kanssa...


Asus P8P67, i5 2500-K @ 3,6Ghz, Scythe Ninja 3, GTX 660 DirectCu II, Fractal Design R3, Seasonic S12 II-520W, PNY SSD, Eizo FORIS FS2331, 12Gb DDR3 1600Mhz@1.65V, Logitech G105 keyboard + g500 mouse.

418.8.2011 13:14

Lisäosien hitaan päivitystahdin takia olen vielä 3.6 versiossa.

Jos versionumeroiden hylkääminen tarkoittaisi sitä, että lisäosat eivät lakkaa uuden version tullessa toimimasta pelkän versionumerotarkistuksen perusteella, voisin olla jopa tämän muutoksen kannalla. Siinä vaan sitten saisi joku päivä ihmetellä, miksi kaikki on rikki, kun joku lisäosa viimein hajoaa muinaisuuteensa.

Firefoxille ja ennen kaikkea sen lisäosille sopi parhaiten perinteinen, hitaasti kasvava versionumerointi. Jos Firefoxissa eivät lisäosat toimi yli kuutta viikkoa kerrallaan, ei sillä ole enää mitään valtteja Chromiumia vastaan.

518.8.2011 14:48

Tuon lisäosa ongelman olen ratkaissut sillä, että olen muuttanut lisäosien maxVersion kenttään aina seuraavan versionumeron. Tähän asti toiminut hyvin...


las ballenas son el camino

619.8.2011 3:52

On se kumma kun ei kukaan ole jaksanut vähän edes nähdä vaivaa lisäosien suhteen: https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/?src=api

Itsellä tällä hetkellä 9.0a1 ja kaikki addonit toiminut 95%. Ja loppuihinkin on tullut päivitys suhteellisen nopeasti.

Tosin onhan tuo lisäosien "rikkoutuminen" päivitysten yhteydessävähän ikävä, vaikka siihen onkin olemassa yksinkertainen ratkaisu.

Mielestäni Firefox on ehdottomasti menossa kovaa vauhtia parempaan suuntaan. Ja Eiköhän tuohon lisäosien yhteensopivuuteen tule jonkinlainen ratkaisu ennemmin tai myöhemmin.


Itse en kyllä versionumeroista luopuisi, mutta kait siihen tottuisi..

719.8.2011 14:47

Tämähän toimenpide olisi pitäny tehdä aikoja sitten, kun versionumeroilla alkoi selainten keskeinen kilpailu.

About-ikkunasta toki täytyy vielä löytyä jonkinlainen järkevästi numeroitu Build-numero, mutta se ei tarvitse läheskään niin paljoa huomiota.

Tämä kaikki ihan sen vuoksi, että olisi vain Mozilla Firefox, eikä Mozilla Firefox 3.6, Mozilla Firefox 4, Mozilla Firefox 5, jne...

Lisäosien yhteensopivuus voitaisiin tarkistaa selaimen omalla toimenpiteellä Mozilla Firefox Addons -sivulla.

827.8.2011 11:57

Miten välttyä FFM päivityksiltä jotka ei toimi XP-käyttöjärjestelmässä. Toinen juttu: jossain uutisoinnissa oli, että Yoono-lisäosaa ei kannata ladata, et sen kanssa tulee ongelmia. Mutta aikaa on kulunut enkä ole huomannut ilmoitusta, että Yoono olisi "korjattu". Tosin ei näytä haittaavan, vaikkei sitä olekaan asennettu.

Tämän uutisen kommentointi ei ole enää mahdollista.

Uutisarkisto